Home Download Buy Blog Forum Support

need help canot install SublimeClang on my ubutun 12.0.4 PC

need help canot install SublimeClang on my ubutun 12.0.4 PC

Postby gilbert1987 on Mon Dec 17, 2012 3:55 pm

Hi,
I encounter a problem when i install the Sublime Clang on my ubutun 12.0.4 system.
I follow the instructions on the:
https://github.com/quarnster/SublimeClang
but when i enter the step:
pythonbrew install --configure="--enable-unicode=ucs4" 2.6
It reported an error:
ERROR: Failed to install Python-2.6. See /home/chen/.pythonbrew/log/build.log to see why.
The error detail is:
Code: Select all
Traceback (most recent call last):
  File "./setup.py", line 1904, in <module>
    main()
  File "./setup.py", line 1899, in main
    'Lib/smtpd.py']
  File "/home/chen/.pythonbrew/build/Python-2.6/Lib/distutils/core.py", line 152, in setup
    dist.run_commands()
  File "/home/chen/.pythonbrew/build/Python-2.6/Lib/distutils/dist.py", line 975, in run_commands
    self.run_command(cmd)
  File "/home/chen/.pythonbrew/build/Python-2.6/Lib/distutils/dist.py", line 995, in run_command
    cmd_obj.run()
  File "/home/chen/.pythonbrew/build/Python-2.6/Lib/distutils/command/build.py", line 134, in run
    self.run_command(cmd_name)
  File "/home/chen/.pythonbrew/build/Python-2.6/Lib/distutils/cmd.py", line 333, in run_command
    self.distribution.run_command(command)
  File "/home/chen/.pythonbrew/build/Python-2.6/Lib/distutils/dist.py", line 995, in run_command
    cmd_obj.run()
  File "/home/chen/.pythonbrew/build/Python-2.6/Lib/distutils/command/build_ext.py", line 343, in run
    self.build_extensions()
  File "./setup.py", line 104, in build_extensions
    missing = self.detect_modules()
  File "./setup.py", line 962, in detect_modules
    sqlite_libdir = [os.path.abspath(os.path.dirname(sqlite_libfile))]
  File "/home/chen/.pythonbrew/build/Python-2.6/Lib/posixpath.py", line 119, in dirname
    i = p.rfind('/') + 1
AttributeError: 'NoneType' object has no attribute 'rfind'


my python verison is
Python 2.7.3 (default, Aug 1 2012, 05:14:39)
[GCC 4.6.3] on linux2

is not 2.6 as required.
I don't know what is happened and how could solve this problem. could any one give me some help on this ? thanks a lot.
gilbert1987
 
Posts: 2
Joined: Mon Dec 17, 2012 3:42 pm

Re: need help canot install SublimeClang on my ubutun 12.0.4 PC

Postby gilbert1987 on Wed Dec 19, 2012 1:34 pm

I have slove this problem, this is a python install issue, you can skip this error by rename the sqlite3.h under /user/include/ folder
gilbert1987
 
Posts: 2
Joined: Mon Dec 17, 2012 3:42 pm


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 35 guests