Home Download Buy Blog Forum Support

Video of Infuriating Bug

Video of Infuriating Bug

Postby frou on Sun Apr 28, 2013 9:29 pm

There has been a long time bug in ST2 and now ST3 that bites me many times a day.

Essentially, using the subl shell command to launch Sublime to view a file has a high chance of showing a blank window instead of the file. I have personally reduced the reproduction to a fresh install of ST3 build 3030 on OS X 10.8.3 with these User Preferences:

Code: Select all
{
   "hot_exit": false,
   "remember_open_files": false
}


CLICK HERE FOR VIDEO

Although I launch and quit Sublime rapidly in the video, this is not needed for the bug to occur. It can occur first thing in the morning after the computer has been idling for 10 hours.

At least 7 other people have have mentioned this bug:
viewtopic.php?f=2&t=11573
viewtopic.php?f=3&t=11029

Please fix it :(
frou
 
Posts: 49
Joined: Sun Jul 31, 2011 11:26 am

Re: Video of Infuriating Bug

Postby frou on Fri May 10, 2013 12:18 pm

...
Last edited by frou on Thu Jul 18, 2013 12:05 am, edited 1 time in total.
frou
 
Posts: 49
Joined: Sun Jul 31, 2011 11:26 am

Re: Video of Infuriating Bug

Postby quarnster on Fri May 10, 2013 12:59 pm

Why are you shutting down the program rather than just closing the window?
quarnster
 
Posts: 389
Joined: Tue Nov 29, 2011 11:34 am

Re: Video of Infuriating Bug

Postby frou on Fri May 10, 2013 1:49 pm

1. Quitting Sublime yields input focus to the Terminal, which closing the bogus window alone doesn't.
2. I don't trust what state Sublime is in if it hasn't started up properly.

As noted in the OP, the rapid cycling isn't particularly relevant. I just did it to show it happening more than once without making a long video.
frou
 
Posts: 49
Joined: Sun Jul 31, 2011 11:26 am

Re: Video of Infuriating Bug

Postby Arjan on Sat May 18, 2013 11:18 am

I'm seeing this too, immensely annoying bug.
Arjan
 
Posts: 88
Joined: Thu Jan 24, 2013 1:08 pm

Re: Video of Infuriating Bug

Postby extempore on Sun Mar 16, 2014 5:46 pm

For any who may come across this thread, please see https://github.com/SublimeText/Issues/issues/27 where I supplied a wrapper subl which works around the issue. The script itself can be found at https://raw.github.com/paulp/homebrew-extras/master/bin/subl and is most easily installed via homebrew:

Code: Select all
brew tap paulp/extras && brew install subl
.
extempore
 
Posts: 2
Joined: Sun Mar 16, 2014 5:18 pm


Return to General Discussion

Who is online

Users browsing this forum: bluejohn, Exabot [Bot], maara, Yahoo [Bot] and 27 guests