Home Download Buy Blog Forum Support

Dev Build 3046

Dev Build 3046

Postby jps on Wed Jun 26, 2013 8:08 am

Dev Build 3046 is out now, with more changes to Python module importing. Hopefully this is the last change required in this area.
jps
Site Admin
 
Posts: 3062
Joined: Wed Mar 19, 2008 12:33 pm

Re: Dev Build 3046

Postby n00ge on Wed Jun 26, 2013 1:39 pm

I'm not sure if this is just an issue with packages that need to be updated but I get this error on quite a few of the packages I have installed:

Code: Select all
File "/Applications/Sublime Text.app/Contents/MacOS/sublime_plugin.py", line 73, in reload_plugin
    m = importlib.import_module(modulename)
  File "X/importlib/__init__.py", line 88, in import_module
  File "<frozen importlib._bootstrap>", line 1577, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1558, in _find_and_load
  File "<frozen importlib._bootstrap>", line 1525, in _find_and_load_unlocked
  File "/Applications/Sublime Text.app/Contents/MacOS/sublime_plugin.py", line 671, in load_module
    exec(compile(source, source_path, 'exec'), mod.__dict__)
Last edited by n00ge on Thu Jun 27, 2013 2:41 am, edited 1 time in total.
http://twitter.com/n00ge
Sublime Text 3 dev builds | OS X 10.8.2 & Ubuntu 13.04
n00ge
 
Posts: 139
Joined: Mon Oct 05, 2009 1:23 am

Re: Dev Build 3046

Postby FichteFoll on Wed Jun 26, 2013 1:47 pm

@n00ge: There seem to be missing the last one or three lines in your traceback (mainly the file that is being "compiled" and at least the actual exception raised).
FichteFoll
 
Posts: 377
Joined: Fri Mar 16, 2012 11:49 pm
Location: Germany

Re: Dev Build 3046

Postby n00ge on Thu Jun 27, 2013 2:40 am

Sorry about that. Here it is:

Code: Select all
Traceback (most recent call last):
  File "/Applications/Sublime Text.app/Contents/MacOS/sublime_plugin.py", line 73, in reload_plugin
    m = importlib.import_module(modulename)
  File "X/importlib/__init__.py", line 88, in import_module
  File "<frozen importlib._bootstrap>", line 1577, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1558, in _find_and_load
  File "<frozen importlib._bootstrap>", line 1525, in _find_and_load_unlocked
  File "/Applications/Sublime Text.app/Contents/MacOS/sublime_plugin.py", line 671, in load_module
    exec(compile(source, source_path, 'exec'), mod.__dict__)
  File "RSpecCreateModule in /Users/n00ge/Library/Application Support/Sublime Text 3/Installed Packages/RSpec.sublime-package", line 3, in <module>


And a few more:

Code: Select all
Traceback (most recent call last):
  File "/Applications/Sublime Text.app/Contents/MacOS/sublime_plugin.py", line 73, in reload_plugin
    m = importlib.import_module(modulename)
  File "X/importlib/__init__.py", line 88, in import_module
  File "<frozen importlib._bootstrap>", line 1577, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1558, in _find_and_load
  File "<frozen importlib._bootstrap>", line 1525, in _find_and_load_unlocked
  File "/Applications/Sublime Text.app/Contents/MacOS/sublime_plugin.py", line 671, in load_module
    exec(compile(source, source_path, 'exec'), mod.__dict__)
  File "Alignment in /Users/n00ge/Library/Application Support/Sublime Text 3/Installed Packages/Alignment.sublime-package", line 10, in <module>


Code: Select all
Traceback (most recent call last):
  File "/Applications/Sublime Text.app/Contents/MacOS/sublime_plugin.py", line 73, in reload_plugin
    m = importlib.import_module(modulename)
  File "X/importlib/__init__.py", line 88, in import_module
  File "<frozen importlib._bootstrap>", line 1577, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1558, in _find_and_load
  File "<frozen importlib._bootstrap>", line 1525, in _find_and_load_unlocked
  File "/Applications/Sublime Text.app/Contents/MacOS/sublime_plugin.py", line 671, in load_module
    exec(compile(source, source_path, 'exec'), mod.__dict__)
  File "html2haml in /Users/n00ge/Library/Application Support/Sublime Text 3/Installed Packages/HTML2Haml.sublime-package", line 1, in <module>


Code: Select all
Traceback (most recent call last):
  File "/Applications/Sublime Text.app/Contents/MacOS/sublime_plugin.py", line 73, in reload_plugin
    m = importlib.import_module(modulename)
  File "X/importlib/__init__.py", line 88, in import_module
  File "<frozen importlib._bootstrap>", line 1577, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1558, in _find_and_load
  File "<frozen importlib._bootstrap>", line 1525, in _find_and_load_unlocked
  File "/Applications/Sublime Text.app/Contents/MacOS/sublime_plugin.py", line 671, in load_module
    exec(compile(source, source_path, 'exec'), mod.__dict__)
  File "JasmineCoffeeScriptDetectFileType in /Users/n00ge/Library/Application Support/Sublime Text 3/Installed Packages/jasmine-coffeescript-tmbundle.sublime-package", line 23
    print "Switched syntax to: " + syntax
http://twitter.com/n00ge
Sublime Text 3 dev builds | OS X 10.8.2 & Ubuntu 13.04
n00ge
 
Posts: 139
Joined: Mon Oct 05, 2009 1:23 am

Re: Dev Build 3046

Postby riddler12 on Thu Jun 27, 2013 3:25 am

Hey n00ge,

I did some googling and here is what I found:

- RSpec (https://github.com/SublimeText/RSpec) seems to be only compatible with Sublime Text 2 at the moment.
- Alignment (https://github.com/wbond/sublime_alignment) as well.
- There were several HTML2Haml plugins and all of them looked to only support Sublime Text 2.
- And in your last trace, jasmine-coffeescript-tmbundle (https://github.com/rsim/jasmine-coffeescript-tmbundle) only supports Sublime Text 2.

If you haven't already seen this yet, wbond has put a great list of Sublime Text 3 compatible packages available here: (https://github.com/wbond/sublime_package_control/wiki/Sublime-Text-3-Compatible-Packages)

I hope this helps you out.
riddler12
 
Posts: 12
Joined: Sun Jun 09, 2013 1:42 pm

Re: Dev Build 3046

Postby Chris--- on Thu Jun 27, 2013 9:14 pm

I do have a problem with this new build, the plugin LaTeXing is working normally if it is unpack in "Packages" but if it is running from the *.sublime-package the following warning comes up:

Code: Select all
Traceback (most recent call last):
  File "C:\Program Files\Sublime Text 3\sublime_plugin.py", line 73, in reload_plugin
    m = importlib.import_module(modulename)
  File "X/importlib/__init__.py", line 88, in import_module
  File "<frozen importlib._bootstrap>", line 1577, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1558, in _find_and_load
  File "<frozen importlib._bootstrap>", line 1525, in _find_and_load_unlocked
  File "C:\Program Files\Sublime Text 3\sublime_plugin.py", line 671, in load_module
    exec(compile(source, source_path, 'exec'), mod.__dict__)
  File "LaTeXing in C:\Documents and Settings\Administrator\Application Data\Sublime Text 3\Installed Packages\LaTeXing3.sublime-package", line 3, in <module>
ImportError: No module named 'LaTeXing3.latexing.bibsonomy'
LaTeXing: LaTeX Plugin for Sublime Text 2 and 3
http://www.latexing.com
Chris---
 
Posts: 25
Joined: Sat Apr 20, 2013 4:49 pm

Re: Dev Build 3046

Postby jps on Fri Jun 28, 2013 2:49 am

With regards to LaTeXing, the .sublime-package file contains .pyc files, which aren't supported by Sublime Text's custom importer
jps
Site Admin
 
Posts: 3062
Joined: Wed Mar 19, 2008 12:33 pm

Re: Dev Build 3046

Postby john_ferrier on Fri Jun 28, 2013 3:11 am

john_ferrier wrote:In C mode and Monokai scheme, if I have a line

#define sign(a) (((a) > 0) - ((a) < 0))

ST display the first "a" in the round bracket as orange and italic.



@jps: can you confirm this is a bug (it is produceable) and will you fix it if it is?
john_ferrier
 
Posts: 20
Joined: Thu Jun 28, 2012 10:37 pm

Re: Dev Build 3046

Postby FichteFoll on Fri Jun 28, 2013 4:06 am

@john_ferrier: As I said, your reported behaviour is not a bug, it's the other way arround. See https://github.com/SublimeText/Issues/issues/71.

However, I'd like to ask @jps what he thinks about having the default packages (C++, Python ...) uploaded to github while having selected people watch over them and just pulling them for every release (maybe checking commits for the changelog). With this we could easily fix issues like this one without having you bother with these external things.
FichteFoll
 
Posts: 377
Joined: Fri Mar 16, 2012 11:49 pm
Location: Germany

Re: Dev Build 3046

Postby wbond on Fri Jun 28, 2013 4:52 am

jps wrote:With regards to LaTeXing, the .sublime-package file contains .pyc files, which aren't supported by Sublime Text's custom importer


This is mostly a mental note for myself, but Package Control is going to need to be updated to always unpack such packages. Until then, package authors can place a file named
Code: Select all
.no-sublime-package
in the root of their package and PC will not re-pack it.
wbond
 
Posts: 523
Joined: Mon Feb 28, 2011 5:33 am

Next

Return to General Discussion

Who is online

Users browsing this forum: Google [Bot] and 20 guests