Home Download Buy Blog Forum Support

Problem on LaTeXTools

Problem on LaTeXTools

Postby Megatron on Tue Sep 10, 2013 9:35 am

.tex file is compiled successfully when i press ctrl-b, but i need to run the sumatrapdf viewer manually.

how do i fix this?

thank you very much.

Code: Select all
[u'latexmk', u'-cd', u'-e', u"$pdflatex = 'xelatex %O -interaction=nonstopmode -synctex=1 %S'", u'-f', u'-pdf', u'C:\\Documents and Settings\\Administrator\\My Documents\\xelatextest\\test.tex']
Welcome to thread Thread-3
3
Finished normally
0
False True True
!TEX root =  u'C:\\Documents and Settings\\Administrator\\My Documents\\xelatextest\\test.tex'
Jump to:  31 1
Windows, Calling Sumatra
Traceback (most recent call last):
  File ".\sublime_plugin.py", line 356, in run_
  File ".\jumpToPDF.py", line 96, in run
  File ".\subprocess.py", line 633, in __init__
  File ".\subprocess.py", line 842, in _execute_child
WindowsError: [Error 2]
Megatron
 
Posts: 2
Joined: Tue Sep 10, 2013 9:27 am

Re: Problem on LaTeXTools

Postby Marciano on Tue Sep 10, 2013 3:38 pm

Did you make sure that sumatra is on your path?
Marciano
 
Posts: 146
Joined: Fri Sep 18, 2009 2:55 am

Re: Problem on LaTeXTools

Postby Megatron on Wed Sep 11, 2013 5:16 am

Marciano wrote:Did you make sure that sumatra is on your path?


yeah

I tested it in cmd and win-r.
Megatron
 
Posts: 2
Joined: Tue Sep 10, 2013 9:27 am

Re: Problem on LaTeXTools

Postby Marciano on Wed Sep 11, 2013 5:01 pm

Hmm... not sure... Error 2 means file not found, and "file" should mean the Sumatra executable here. Do things work if you don't use a custom build engine? Just trying to rule things out...
Marciano
 
Posts: 146
Joined: Fri Sep 18, 2009 2:55 am


Return to General Discussion

Who is online

Users browsing this forum: Yahoo [Bot] and 19 guests