Home Download Buy Blog Forum Support

Regarding plugin_host

Regarding plugin_host

Postby Barneydog91 on Sat Jul 12, 2014 6:34 am

Hi,

I installed Sublime Text Build 3059 a few weeks ago, as well as several different plugins. Up until the last few days, the plugins worked perfectly, but now, plugin_host crashes whenever I open Sublime Text. A message tells me to restart SB to get back plugin functionality, but plugin_host just crashes every time. Help, I don't want to have to reinstall SB and all my plugins!
Barneydog91
 
Posts: 2
Joined: Sat Jul 12, 2014 6:30 am

Re: Regarding plugin_host

Postby iamntz on Sat Jul 12, 2014 7:47 am

You could remove plugins one by one and see who is the culprit.
iamntz
 
Posts: 918
Joined: Fri Apr 29, 2011 8:52 am
Location: Romania

Re: Regarding plugin_host

Postby FichteFoll on Sat Jul 12, 2014 1:25 pm

You can also "just" disable them. Technically this doesn't make a lot of a difference but you won't have to install them again and only need to enable afterwards.

Package Control provides commands for this.
FichteFoll
 
Posts: 408
Joined: Fri Mar 16, 2012 11:49 pm
Location: Germany

Re: Regarding plugin_host

Postby iamntz on Sat Jul 12, 2014 1:38 pm

@FichteFoll: good luck disabling via PC (or run any plugin actually) when plugin_host is gone! :geek:
iamntz
 
Posts: 918
Joined: Fri Apr 29, 2011 8:52 am
Location: Romania

Re: Regarding plugin_host

Postby jbrooksuk on Sat Jul 12, 2014 5:10 pm

What plugins do you have installed? SublimeCodeIntel always slows down for me.
jbrooksuk
 
Posts: 782
Joined: Sun Apr 11, 2010 10:37 am
Location: England

Re: Regarding plugin_host

Postby FichteFoll on Sun Jul 13, 2014 3:43 am

Whops, didn't read it crashed on startup. Well, good luck indeed.
FichteFoll
 
Posts: 408
Joined: Fri Mar 16, 2012 11:49 pm
Location: Germany

Re: Regarding plugin_host

Postby Barneydog91 on Mon Jul 14, 2014 4:09 am

Barneydog91 wrote:Hi,

I installed Sublime Text Build 3059 a few weeks ago, as well as several different plugins. Up until the last few days, the plugins worked perfectly, but now, plugin_host crashes whenever I open Sublime Text. A message tells me to restart SB to get back plugin functionality, but plugin_host just crashes every time. Help, I don't want to have to reinstall SB and all my plugins!


I copied everything out of my package folder in %appdata%, then reinstalled Sublime, and pasted my packages back. The plugin_host stopped crashing, and all my plugins work again.
Barneydog91
 
Posts: 2
Joined: Sat Jul 12, 2014 6:30 am


Return to General Discussion

Who is online

Users browsing this forum: Google [Bot] and 18 guests