Home Download Buy Blog Forum Support

Dev Build 2147

Dev Build 2147

Postby jps on Thu Dec 15, 2011 8:17 am

Dev Build 2147 is out now. Some of the changes are:

* Hexadecimal encoding. Files may be opened as hex, which allows editing binary files in a meaning manner. While this does enable editing binary files, it's not a hex editing mode per-se, and I'm not planning on adding any further functionality here. It exists so binary files, when opened as a preview by Goto Anything, are displayed in a reasonable manner. It also reduces font glyph rasterisation load, which binary files used to cause, so you'll no longer get a hitch when previewing binary files.

* OSX: When editing files you don't have permission to edit, you'll be prompted for elevated privileges to save the file. This enables editing of /etc/hosts, for example.
jps
Site Admin
 
Posts: 3058
Joined: Wed Mar 19, 2008 12:33 pm

Re: Dev Build 2147

Postby gavsim on Thu Dec 15, 2011 9:05 am

Great work Jon!
gavsim
 
Posts: 9
Joined: Wed Oct 26, 2011 9:35 pm

Re: Dev Build 2147

Postby buymeasoda on Thu Dec 15, 2011 9:13 am

jps wrote:OSX: When editing files you don't have permission to edit, you'll be prompted for elevated privileges to save the file. This enables editing of /etc/hosts, for example.


So happy to see this feature added. It was the only reason I still had a separate copy of TextMate installed, for quick editing of the hosts file.

Great work.
buymeasoda
 
Posts: 63
Joined: Mon Jul 18, 2011 11:40 pm
Location: Brisbane, Australia

Re: Dev Build 2147

Postby ekolguy on Thu Dec 15, 2011 10:41 am

buymeasoda wrote:
jps wrote:OSX: When editing files you don't have permission to edit, you'll be prompted for elevated privileges to save the file. This enables editing of /etc/hosts, for example.


So happy to see this feature added. It was the only reason I still had a separate copy of TextMate installed, for quick editing of the hosts file.

Great work.



+ 999
ekolguy
 
Posts: 41
Joined: Thu Dec 17, 2009 8:50 am

Re: Dev Build 2147

Postby corelon on Thu Dec 15, 2011 11:19 am

Hello.
Is it possible to have some option to disable bold and italic for the themes? One reason I love this editor is that it allowed me to use textmate theme with fonts that do not have bold and italic variants. Please add this in the options.

Cheers,
Nick Tzanos
corelon
 
Posts: 41
Joined: Mon Feb 16, 2009 2:16 pm

Re: Dev Build 2147

Postby dazld on Thu Dec 15, 2011 12:10 pm

hey, I'm just wondering what happened to the alt+shift+w behaviour? I've had to regress to an earlier build because of this.

I'm not sure why it's asking me to enter a haiku, when I want to create an XML/HTML element? Feeling poetic? :)

(Linux/Ubuntu @ 64bit, build 2147)
dazld
 
Posts: 2
Joined: Thu Dec 15, 2011 12:09 pm

Re: Dev Build 2147

Postby dazld on Thu Dec 15, 2011 12:14 pm

Nevermind, it was the zencoding package confusing me :) Sorry!
dazld
 
Posts: 2
Joined: Thu Dec 15, 2011 12:09 pm

Re: Dev Build 2147

Postby reddshack on Thu Dec 15, 2011 12:23 pm

ekolguy wrote:
buymeasoda wrote:
jps wrote:OSX: When editing files you don't have permission to edit, you'll be prompted for elevated privileges to save the file. This enables editing of /etc/hosts, for example.


So happy to see this feature added. It was the only reason I still had a separate copy of TextMate installed, for quick editing of the hosts file.

Great work.



+ 999

Thank you! The ONLY reason I ever open TM.

+1
reddshack
 
Posts: 20
Joined: Fri Jan 07, 2011 8:56 am

Re: Dev Build 2147

Postby mok on Thu Dec 15, 2011 2:52 pm

Any reason why some italicized fonts are clipped? I have been seeing this ever since italicized accents were introduced a build or two ago. Screenshot: http://imm.io/cZBB

Here is my Base File.sublime-settings
Code: Select all
{
   "color_scheme": "Packages/Color Scheme - Default/Monokai.tmTheme",
   "font_face": "Ubuntu Mono",
   "font_options": "subpixel_antialias",
   "font_size": 11
}
mok
 
Posts: 6
Joined: Sat Jul 02, 2011 6:45 pm

Re: Dev Build 2147

Postby Marciano on Thu Dec 15, 2011 3:30 pm

Jon, I still cannot see italics/bold on OSX. I have everything set to default (I removed my font/theme customization). For isntance, I saw in some posts that comments in Python and settings files are italicized; I don't see that. What could be wrong on my side? Thanks!
Marciano
 
Posts: 143
Joined: Fri Sep 18, 2009 2:55 am

Next

Return to General Discussion

Who is online

Users browsing this forum: Google [Bot] and 7 guests

cron