Home Download Buy Blog Forum Support

Dev Build 2174

Re: Dev Build 2174

Postby jbrooksuk on Thu Feb 02, 2012 10:08 am

I love the fact that settings are merged. Some times it was pain when you're in a rush to get them in the right place!
jbrooksuk
 
Posts: 763
Joined: Sun Apr 11, 2010 10:37 am
Location: England

Re: Dev Build 2174

Postby Hinano on Thu Feb 02, 2012 10:25 am

thanks for the update. it looks like the formatting for setting the theme has changed. any suggestions for getting the Soda theme working again? thanks again
Hinano
 
Posts: 3
Joined: Thu Feb 02, 2012 10:21 am

Re: Dev Build 2174

Postby Hinano on Thu Feb 02, 2012 10:50 am

Nevermind, figured it out. Added the 'theme' line to the Preferences > Settings -- Users

{
"color_scheme": "Packages/Color Scheme - Default/Twilight.tmTheme",
"theme": "Soda Dark.sublime-theme",
"font_face": "Consolas",
"font_size": 11.0
}
Hinano
 
Posts: 3
Joined: Thu Feb 02, 2012 10:21 am

Re: Dev Build 2174

Postby handycam on Thu Feb 02, 2012 12:56 pm

tanepiper wrote:Great work!

Also, Mac owners can install Consolas too - http://www.wezm.net/technical/2009/03/i ... as-mac-osx - it's a great looking font on the Mac too


If you have a recent version of Office Mac installed, you already have it.

Also, check this out: http://hivelogic.com/articles/top-10-programming-fonts/
Mac OS 10.9.3
ST 3 (3059)
handycam
 
Posts: 271
Joined: Tue Jan 03, 2012 2:42 pm

Re: Dev Build 2174

Postby hubert on Thu Feb 02, 2012 2:10 pm

OSX: when the default settings have the entry "word_wrap": "auto" then word wrap can't be activated, neither through the user settings or the menu.
hubert
 
Posts: 31
Joined: Mon Jan 09, 2012 12:12 pm

Re: Dev Build 2174

Postby n00ge on Thu Feb 02, 2012 2:32 pm

OSX: when the default settings have the entry "word_wrap": "auto" then word wrap can't be activated, neither through the user settings or the menu.

I just came across this as well.
http://twitter.com/n00ge
Sublime Text 3 dev builds | OS X 10.8.2 & Ubuntu 13.04
n00ge
 
Posts: 140
Joined: Mon Oct 05, 2009 1:23 am

Re: Dev Build 2174

Postby arneson on Thu Feb 02, 2012 3:52 pm

Appreciate the update as always. However this build has been pretty buggy for our team. We noticed that our settings for ignored files and folders ("folder_exclude_patterns" and "file_exclude_patterns") were blown away, presumably something to do with merging User and Global settings. Another things we've noticed is that we're seeing word wrapping, even though "word_wrap": false in Settings - User. We can change it in Settings - Default and it works, but when using Settings - User like before, it does not override it. Sounds like this one has been mentioned a couple times.
arneson
 
Posts: 5
Joined: Mon Dec 19, 2011 5:29 pm

Re: Dev Build 2174

Postby jbrooksuk on Thu Feb 02, 2012 4:53 pm

On OSX I can't get word_wrap to work any longer.
jbrooksuk
 
Posts: 763
Joined: Sun Apr 11, 2010 10:37 am
Location: England

Re: Dev Build 2174

Postby danro on Thu Feb 02, 2012 5:19 pm

Nope, JavaScript and JSON auto-indent is still broken. I must revert to 2172 to fix.

Here's a nice little animation for you.
Image

EDIT: here is my Preferences file. When I delete all packages & restart, the indent seems to work, so it must be one of these settings.

Code: Select all
{
   "auto_complete_commit_on_tab": true,
   "auto_complete_with_fields": true,
   "auto_match_enabled": true,
   "color_scheme": "Packages/User/colors/DanroST2.tmTheme",
   "detect_indentation": true,
   "draw_indent_guides": true,
   "fade_fold_buttons": false,
   "folder_exclude_patterns":
   [
      ".svn",
      ".git",
      ".hg",
      "CVS",
      "dist"
   ],
   "font_face": "Monaco",
   "font_options":
   [
      "no_antialias"
   ],
   "font_size": 11.0,
   "ignored_packages":
   [
      "Vintage"
   ],
   "jshint_options":
   {
      "asi": true,
      "browser": true,
      "eqnull": true,
      "evil": true,
      "expr": true,
      "laxcomma": true,
      "loopfunc": true,
      "trailing": true,
      "undef": true,
      "validthis": true
   },
   "line_padding_top": 1,
   "match_selection": false,
   "open_files_in_new_window": false,
   "scroll_past_end": true,
   "scroll_speed": 0,
   "sublimelinter_delay": 1,
   "tab_size": 2,
   "theme": "Soda Dark.sublime-theme",
   "translate_tabs_to_spaces": true,
   "tree_animation_enabled": false,
   "trim_automatic_white_space": false,
   "word_separators": "./\\()\"'-:,.;<>~!#%&^*|+=[]{}`~?"
}
Last edited by danro on Thu Feb 02, 2012 7:17 pm, edited 2 times in total.
danro
 
Posts: 19
Joined: Thu May 19, 2011 5:39 am
Location: Sacramento, CA

Re: Dev Build 2174

Postby tito on Thu Feb 02, 2012 5:29 pm

Not sure when, but "tab character" is not working as expected. "tab" should insert a "tab" and nothing more.

In the following example cursor is at the end
Code: Select all
class nada:

   def nada():
      hoola()

|


When I hit "TAB" cursor changes to :
Code: Select all
class nada:

   def nada():
      hoola()

      |


"TAB" should work as a tab character, instead of trying to guess
Give APIs, let the community build the rest!
https://github.com/titoBouzout
tito
 
Posts: 854
Joined: Thu Sep 29, 2011 2:27 pm
Location: Montevideo, Uruguay

PreviousNext

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 18 guests