Home Download Buy Blog Forum Support

Launching speed

Launching speed

Postby Gryzor on Fri Oct 23, 2009 7:56 am

Hello,

Up to now I've been using SCiTE, but Sublime tempts me...

It looks and behaves really nice, but there's one big drawback: it takes a long time to launch. This is a bit annoying when you work with lots of small files, opening and closing the program... Any ways to remedy this?

Great job, thanks for a lovely program :)
Gryzor
 
Posts: 3
Joined: Fri Oct 23, 2009 7:54 am

Re: Launching speed

Postby jps on Fri Oct 23, 2009 11:23 am

I agree this is becoming an issue, especially as more syntax files are added. I'll try and look at it soon.

In the mean time, you can just leave Sublime Text open :)
jps
Site Admin
 
Posts: 3071
Joined: Wed Mar 19, 2008 12:33 pm

Re: Launching speed

Postby Gryzor on Fri Oct 23, 2009 1:04 pm

Ah, so it's the syntax files that do that. I suspected that much... Since I only use a very small subset of the whole list, how do I go about removing the ones I don't need?
Gryzor
 
Posts: 3
Joined: Fri Oct 23, 2009 7:54 am

Re: Launching speed

Postby jps on Fri Oct 23, 2009 1:32 pm

You can delete the .tmLanguage files, but there's no simple way to get them back, I recommend waiting till the next beta.
jps
Site Admin
 
Posts: 3071
Joined: Wed Mar 19, 2008 12:33 pm

Re: Launching speed

Postby Gryzor on Sat Oct 24, 2009 6:15 am

Ok, I'll wait to see the difference :)
Gryzor
 
Posts: 3
Joined: Fri Oct 23, 2009 7:54 am

Re: Launching speed

Postby Phrogz on Tue Mar 02, 2010 4:26 pm

Note that this is still an issue, and the only one preventing me from purchasing Sublime. I have a rather beefy machine (i7 860 @ 2.8GHz, 8GB RAM, 10k RPM HD) and Sublime takes over 7 seconds to launch, even immediately after I have just run and quit it. By comparison, 'e' text editor takes about 0.8 seconds to launch for me (immediately after quit). I can't use Sublime with this level of startup lag.
Phrogz
 
Posts: 18
Joined: Tue Mar 02, 2010 4:21 pm

Re: Launching speed

Postby jhawk28 on Tue Mar 02, 2010 5:25 pm

Phrogz wrote:Note that this is still an issue, and the only one preventing me from purchasing Sublime. I have a rather beefy machine (i7 860 @ 2.8GHz, 8GB RAM, 10k RPM HD) and Sublime takes over 7 seconds to launch, even immediately after I have just run and quit it. By comparison, 'e' text editor takes about 0.8 seconds to launch for me (immediately after quit). I can't use Sublime with this level of startup lag.


I have a feeling there may be something else going on because I have much lower system specs and it takes me about 1-2 seconds to launch.
jhawk28
 
Posts: 26
Joined: Sat Jun 13, 2009 2:17 pm

Re: Launching speed

Postby AndrejMitrovic on Tue Mar 02, 2010 5:39 pm

Phrogz wrote:Note that this is still an issue, and the only one preventing me from purchasing Sublime. I have a rather beefy machine (i7 860 @ 2.8GHz, 8GB RAM, 10k RPM HD) and Sublime takes over 7 seconds to launch, even immediately after I have just run and quit it. By comparison, 'e' text editor takes about 0.8 seconds to launch for me (immediately after quit). I can't use Sublime with this level of startup lag.

It takes about ~1 seconds on an Athlon II X4, XP SP3. There might be something else preventing the app to run immediately. Perhaps a firewall or antivirus is checking the app as it starts to run?
AndrejMitrovic
 
Posts: 7
Joined: Sun Feb 28, 2010 4:16 am

Re: Launching speed

Postby Phrogz on Wed Mar 17, 2010 3:28 pm

Phrogz wrote:Note that this is still an issue, and the only one preventing me from purchasing Sublime. I have a rather beefy machine (i7 860 @ 2.8GHz, 8GB RAM, 10k RPM HD) and Sublime takes over 7 seconds to launch, even immediately after I have just run and quit it. By comparison, 'e' text editor takes about 0.8 seconds to launch for me (immediately after quit). I can't use Sublime with this level of startup lag.


I have no idea what was up with my machine when I made that timing (repeatedly). Sublime now launches for me in ~1 second, which is sufficient. Thanks for the posters calling into question my FUD and getting me to check again.
Phrogz
 
Posts: 18
Joined: Tue Mar 02, 2010 4:21 pm

Re: Launching speed

Postby gtipton on Fri Mar 19, 2010 8:57 pm

I regularly get mixed results regarding startup time, and it's probably my biggest issue with Sublime. If I am starting it for the first time after booting my computer, it's fairly speedy. However, if my system has gone into standby for any amount of time it seems like Sublime takes quite a while to launch - sometimes updward of 20 seconds. My system isn't extremely powerful, but it's decent enough (~dual core 2.0 Ghz).

If Sublime was open when my system went into standby, it can often take 20-30 seconds to "wake up" and render on the screen. This is probably my biggest gripe. Otherwise, I still enjoy it and use it as my primary text editor.

* Oh, and I only have a couple plugins installed.
gtipton
 
Posts: 4
Joined: Sun May 31, 2009 6:17 pm

Next

Return to General Discussion

Who is online

Users browsing this forum: macula and 19 guests