Home Download Buy Blog Forum Support

New CSS autocompletions only partially working

New CSS autocompletions only partially working

Postby minimalweb on Wed Jun 20, 2012 8:17 am

Not all of the property values are completed as expected. I looked in the css_completions.py file and it seems that all properties that are written like this

Code: Select all
"overflow"=visible | hidden | scroll | auto | inherit
"float"=left | right | none | inherit


do work, but the ones where there is
Code: Select all
<…>
somewhere, don't.

Code: Select all
"height"=<length> | <percentage> | auto | inherit
"right"=<length> | <percentage> | auto | inherit
"outline-color"=<color> | invert | inherit


For example, I can write
Code: Select all
float: l|
and get a completion for "left".

But if i write
Code: Select all
height: a|
no completion for "auto" shows up.

I am running build 2203 on OS X 10.7.4
minimalweb
 
Posts: 10
Joined: Sun Oct 02, 2011 7:22 pm

Re: New CSS autocompletions only partially working

Postby ninjaroll on Thu Jun 21, 2012 10:46 pm

Not sure what the "|" represents in your examples, but for me, I just create new snippets under User/

Example, I have a file in there named "float-left-(float).sublime-snippet". In it I have this:
Code: Select all
<snippet>
    <content><![CDATA[float: left;$0]]></content>
    <tabTrigger>fll</tabTrigger>
    <scope>source.css</scope>
    <description>float: left</description>
</snippet>


What this does is automatically type out "float: left;" when I type "fll" and then hit Tab.
ninjaroll
 
Posts: 31
Joined: Tue Jan 03, 2012 7:10 pm

Re: New CSS autocompletions only partially working

Postby minimalweb on Fri Jun 22, 2012 8:09 am

The | is the caret.

I know about snippets and there are several packages out there, that do just that. But still, the package bundled with the product should work properly, shouldn't it? I just want to help, because it seems like a bug to me, that might be easily fixed.
minimalweb
 
Posts: 10
Joined: Sun Oct 02, 2011 7:22 pm

Re: New CSS autocompletions only partially working

Postby minimalweb on Tue Jun 26, 2012 9:44 am

I just installed build 2207 and it seems to work fine now. Thank you!
minimalweb
 
Posts: 10
Joined: Sun Oct 02, 2011 7:22 pm


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 20 guests