Home Download Buy Blog Forum Support

GLIBC 2.11 requirement

GLIBC 2.11 requirement

Postby thekyz on Fri Jun 29, 2012 9:54 am

Hi,

I would like to know if it would be possible to make SublimeText2 not dependent on such a recent version of the GLIBC, or maybe embark its requirements. As it is, it's very complicated to have SublimeText2 running on Linux in a professional environment since GLIBC after version 2.7 is not compatible with all OSs.

Is there such a need for a strong dependency against GLIBC 2.11 ?

More on this problem around here, basically people using CentOS RHEL5 cannot use SublimeText2:
http://sublimetext.userecho.com/topic/2 ... tosrhel-5/
thekyz
 
Posts: 20
Joined: Fri Feb 04, 2011 9:27 am

Re: GLIBC 2.11 requirement

Postby codecraig on Wed Nov 21, 2012 3:24 am

I'd also like to use sublime against an older GLIBC. (I've also commented on the thread that this post links to)
codecraig
 
Posts: 1
Joined: Wed Nov 21, 2012 3:23 am

Re: GLIBC 2.11 requirement

Postby qgates on Thu Nov 22, 2012 4:45 am

The best solution to this would be for Jon to release a statically-linked version of Sublime. The binaries will be bigger, but it should then work on most platforms.

S
qgates
 
Posts: 209
Joined: Mon Nov 05, 2012 4:33 pm


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 19 guests