Home Download Buy Blog Forum Support

Vintage + Zen Issue with Colon Key

Vintage + Zen Issue with Colon Key

Postby adamup on Mon Oct 15, 2012 2:01 am

Hi -

When both Vintage mode and the Zen Coding package are installed/enabled, there is a key-binding conflict with the colon (':').

To reproduce:
Type ":" (the Vim symbol to preface a command) while the cursor is in the first space of a line. A colon is printed into the file instead of being passed to the vim command line.

So far, I've only noticed this behavior in CSS files.

Let me know if there's any work around! Thanks,

Adam
adamup
 
Posts: 1
Joined: Mon Oct 15, 2012 1:55 am

Re: Vintage + Zen Issue with Colon Key

Postby improvono on Mon Oct 22, 2012 3:58 pm

Yeah there is a key binding for CSS files and zen coding you don't really need. Head to:

Preferences > Package Settings > ZenCoding > Bindings > Key Bindings: Default and comment out this section:

{"__doc__": "Override for the binding in CSS/*.sublime-keymap",
"args": {"contents": ":"},
"command": "insert_snippet",
"context": [{"key": "setting.auto_match_enabled",
"operand": true,
"operator": "equal"},
{"key": "selection_empty",
"match_all": true,
"operand": true,
"operator": "equal"},
{"key": "selector",
"match_all": true,
"operand": "source.css - meta.selector.css",
"operator": "equal"},
{"key": "following_text",
"match_all": true,
"operand": "^(?:\t| |\\}|$)",
"operator": "regex_contains"}],
"keys": [":"]},

That did the trick for me.
improvono
 
Posts: 1
Joined: Mon Oct 22, 2012 3:56 pm


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot], Google [Bot] and 10 guests