Home Download Buy Blog Forum Support

Platform identifier missing when using shared settings

Platform identifier missing when using shared settings

Postby janfoeh on Thu Nov 15, 2012 12:20 pm


this is just a minor bug report - I'm mostly sharing this for others who might run into the same problem.

Short version:

* when using Sublime for the first time with settings created on another machine, the platform identifier was empty
* because of this, Sublime tried to locate the keymap file at Default ().sublime-keymap
* deleting Packages/Default/Startup.cache and reopening Sublime on the second machine first made the problem go away


I use Sublime on two different machines (Macbook Air and iMac, both running OS X 10.8.2) and have them share their settings through Dropbox.
To this end, I have symlinked ~/Library/Application Support/Sublime Text 2/[Installed Packages|Packages|Pristine Packages] to their respective locations in my Dropbox folder.

The settings files where created by Sublime on my laptop. When I first launched Sublime on my desktop, I was unable to modify my keyboard shortcuts, since Sublime tried to locate the preference files at Default ().sublime-keymap.

On a hunch, I deleted the Startup.cache and restarted Sublime on the desktop. The issue then disappeared; I can now use the shared settings on both machines without issues.
Posts: 1
Joined: Thu Nov 15, 2012 11:41 am

Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 12 guests