Home Download Buy Blog Forum Support

Can't run on RHEL 5.5 - Please Help

Can't run on RHEL 5.5 - Please Help

Postby longphant on Thu Nov 29, 2012 3:39 pm

Hi,

I am using Redhat Enterprise Enterprise Linux 5.5 (it's for work, can't upgrade). I'm getting this error:
./sublime_text: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by ./sublime_text)
./sublime_text: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./sublime_text)
./sublime_text: /lib/libc.so.6: version `GLIBC_2.11' not found (required by ./sublime_text)


>>rpm -q glibc
glibc-2.5-49.x86_64
glibc-2.5-49.i686


>>strings /usr/lib/libstdc++.so.6 | grep GLIBC
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBC_2.3
GLIBC_2.0
GLIBC_2.3.2
GLIBC_2.4
GLIBC_2.1
GLIBC_2.1.3
GLIBC_2.2
GLIBCXX_FORCE_NEW



How can I get this working?
longphant
 
Posts: 3
Joined: Thu Nov 29, 2012 3:35 pm

Re: Can't run on RHEL 5.5 - Please Help

Postby qgates on Thu Nov 29, 2012 3:49 pm

Don't use RHEL but from your post it looks like you need newer version of the glibc libraries. See if you can find the newer library for your distro, I'm sure it will be out there on a repo somewhere, even if it's not on the "official" repo for RHEL 5.5. Unfortunately "Enterprise" and "Server" distros tend to hang back on older versions of some packages, the thinking being that they're likely to be more stable/compatible/proven.

RHEL 6 has it so I'm sure it'll be available in some backports repo. If not you can always try installing the RHEL6 one by hand.

S
qgates
 
Posts: 205
Joined: Mon Nov 05, 2012 4:33 pm


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 25 guests