Home Download Buy Blog Forum Support

HTML style and script tags not behaving themselves.

HTML style and script tags not behaving themselves.

Postby kabadesu on Mon Dec 10, 2012 4:02 am

At first I thought this issue was being caused by the Tag plugin, but further investigation shows that something else is going on.

When using the Tag plugin to close a tag when I type </ I am getting incorrect closing tags.

In this case I am trying to close the style tag.
Capture-style.JPG
Capture-style.JPG (28.63 KiB) Viewed 463 times


In this case I am trying to close the script tag.
Capture-script.JPG
Capture-script.JPG (27.78 KiB) Viewed 462 times


At first I thought it had something to do with the plugin until I disabled it and tried a few different highlighting themes. This theme shows the style tag looking a lot like the comment section above.

Capture2.JPG
Capture2.JPG (33.97 KiB) Viewed 463 times
Last edited by kabadesu on Mon Dec 10, 2012 9:01 pm, edited 1 time in total.
kabadesu
 
Posts: 31
Joined: Wed Feb 29, 2012 9:28 am

Re: HTML style and script tags not behaving themselves.

Postby kabadesu on Mon Dec 10, 2012 4:06 am

And here is a simplified version of the last example (using Cobalt theme). However in this version the style tag is clearly not coming up as a comment, but rather something else.

Capture3.JPG
Capture3.JPG (14.95 KiB) Viewed 462 times


When I enable the Tag plugin, I'm back to have incorrect closing tags.

Capture4.JPG
Capture4.JPG (13.75 KiB) Viewed 463 times


It's quite tricky to explain this one.

It's happening in Build 2219 and 2.0.1 on both Mac and PC (both versions tested on each).
kabadesu
 
Posts: 31
Joined: Wed Feb 29, 2012 9:28 am


Return to Technical Support

Who is online

Users browsing this forum: No registered users and 26 guests