Home Download Buy Blog Forum Support

Can´t connect to repository_channels by https

Can´t connect to repository_channels by https

Postby diezdedos on Sun Dec 30, 2012 4:44 pm

I don´t use proxy; and I make a new clean installation before post this.
I try to find a solution, but no lucky.

Package Control settings:
Code: Select all
"repository_channels": [
      "https://sublime.wbond.net/repositories.json"
   ],
   
   // A list of URLs that contain a packages JSON file. These repositories
   // are placed in order before repositories from the "repository_channels"
   // setting
   "repositories": [],

   "certs": {
      "sublime.wbond.net": ["7f4f8622b4fd001c7f648e09aae7edaa", ""]
   },


Error on console:
Code: Select all
Package Control: Download Debug
  URL: https://sublime.wbond.net/repositories.json
  Resolved IP: 50.116.34.243
  Timeout: 30
Package Control: Urllib2 Debug Proxy
  http_proxy:
  https_proxy:
  proxy_username:
  proxy_password:
Package Control: Urllib2 HTTPS Debug General
  Connecting to sublime.wbond.net on port 443
Package Control: Urllib2 HTTPS Debug General
  Connecting to sublime.wbond.net on port 443
  CA certs file at C:\Users\Eduardo\AppData\Roaming\Sublime Text 2\Packages\Package Control\certs\ca-bundle.crt
Package Control: Error downloading channel. HTTP exception InvalidCertificateException (Host sublime.wbond.net returned an invalid certificate (_ssl.c:480: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed)
) downloading https://sublime.wbond.net/repositories.json.
Package Control: Download Debug
  URL: https://sublime.wbond.net/testing/packages.json
  Resolved IP: 50.116.34.243
  Timeout: 30
Package Control: Urllib2 Debug Proxy
  http_proxy:
  https_proxy:
  proxy_username:
  proxy_password:
Package Control: Urllib2 HTTPS Debug General
  Connecting to sublime.wbond.net on port 443
Package Control: Urllib2 HTTPS Debug General
  Connecting to sublime.wbond.net on port 443
  CA certs file at C:\Users\Eduardo\AppData\Roaming\Sublime Text 2\Packages\Package Control\certs\ca-bundle.crt
Package Control: Error downloading repository. HTTP exception InvalidCertificateException (Host sublime.wbond.net returned an invalid certificate (_ssl.c:480: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed)
) downloading https://sublime.wbond.net/testing/packages.json.
error: Package Control: There are no packages available for installation.


Thanks in advance,
Eduardo
diezdedos
 
Posts: 6
Joined: Thu Apr 26, 2012 12:14 pm

Re: Can´t connect to repository_channels by https

Postby wbond on Sun Dec 30, 2012 5:28 pm

From all of the bug reports I have had related to this issue in the past, it is almost certainly some sort of firewall or anti-virus software that is causing this. Try to white-list the sublime_text binary to make sure something isn't messing with the connection.
wbond
 
Posts: 531
Joined: Mon Feb 28, 2011 5:33 am

Re: Can´t connect to repository_channels by https

Postby diezdedos on Sun Jan 06, 2013 3:12 pm

Thanks so much for your reply wbond!
I fix it allowing it on my nod32 antivirus.
diezdedos
 
Posts: 6
Joined: Thu Apr 26, 2012 12:14 pm


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot] and 19 guests