Home Download Buy Blog Forum Support

Bug: Changed files not reloading on double-pane layout

Bug: Changed files not reloading on double-pane layout

Postby Tanaric on Fri Mar 12, 2010 8:35 pm

In release version 1.3.

Repro steps:

1. Switch to vertical 2-panel layout
2. Open up a bunch of tabs in each layout
3. Have the left layout panel have focus
4. Change files in another editor/git checkout/etc
5. Click on right layout panel. Sublime asks you if you want to reload the file in the left layout panel. Hit okay and it does this, left layout panel now has focus.
6. Click on right layout panel. Sublime asks you if you want to reload the file in the right layout panel. Hit okay and it does nothing! The old file is still in the right layout panel but there's no indication of this anywhere.

Note that if you click on a tab directly, in either panel as far as I've tested, the tab is reloaded successfully. It appears to be only precisely the above case that fails (though it also fails in reverse -- if you go from right panel focus to left panel).
Tanaric
 
Posts: 8
Joined: Fri Feb 05, 2010 11:46 pm

Re: Bug: Changed files not reloading on double-pane layout

Postby GreyWyvern on Tue Mar 16, 2010 10:24 pm

Well, something is going on here because I am crashing 20100217 (Win XP) by performing the following steps:

1. Open ST in vertical double pane layout (Alt + 2)
2. Open a new untitled document in each pane and type some text into each one.
3. Save both files as txt documents to the desktop.
4. Open both files up in a different text editor, change and save both.
5. Refocus ST, which will prompt you to refresh the file in the focused pane. Choose "Yes".
6. Click the other pane which will prompt you to refresh the file in that pane. Choose "Yes".

ST crashes with the message: "Assertion failed in .\text\text_buffer.cpp:750: m_constructionDepth > 0"
GreyWyvern
 
Posts: 106
Joined: Fri Oct 23, 2009 7:08 pm
Location: Canadia

Re: Bug: Changed files not reloading on double-pane layout

Postby Tanaric on Tue Mar 16, 2010 11:16 pm

Forgot to mention, sometimes I get that assertion error too.
Tanaric
 
Posts: 8
Joined: Fri Feb 05, 2010 11:46 pm


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 36 guests