Home Download Buy Blog Forum Support

Search not working

Search not working

Postby cobadger on Fri Jan 18, 2013 5:21 pm

Search isn't working in my Mac version of SublimeText 2.

If I enter a search term which appears in a document (e.g. "foo") I get a message at the bottom left of the application window that says "[x=number] matches; Unable to find foo".

I uninstalled and reinstalled the program. What else might I try?
cobadger
 
Posts: 2
Joined: Fri Jan 18, 2013 5:16 pm

Re: Search not working

Postby cobadger on Fri Jan 18, 2013 5:29 pm

More bizarre behavior: some text searches work, but when they do the "Find Prev" button finds the *next* occurrence of the search term, and the "Find" button finds the previous occurrence.
cobadger
 
Posts: 2
Joined: Fri Jan 18, 2013 5:16 pm

Re: Search not working

Postby Deacalion on Tue Feb 19, 2013 8:35 am

I'm having the same problem. Version 2.0.1, Build 2217.
Deacalion
 
Posts: 3
Joined: Wed Jan 11, 2012 3:10 pm

Re: Search not working

Postby jps on Wed Feb 20, 2013 12:11 am

It sounds like you have the 'Reverse' button checked on the Find panel.
jps
Site Admin
 
Posts: 3058
Joined: Wed Mar 19, 2008 12:33 pm

Re: Search not working

Postby schlamar on Wed Feb 20, 2013 1:02 pm

About the first issue: You are probably searching only in the current selection.
schlamar
 
Posts: 102
Joined: Tue Feb 19, 2013 2:11 pm

Re: Search not working

Postby Deacalion on Tue Mar 12, 2013 5:10 am

Problem solved: I had the “Whole word (Alt+W)” option selected, after toggling it to off my searches started working.

Thanks jps for pointing me in the right direction.
Deacalion
 
Posts: 3
Joined: Wed Jan 11, 2012 3:10 pm


Return to Technical Support

Who is online

Users browsing this forum: Fatbat, Jun__33, Yahoo [Bot] and 16 guests

cron