Home Download Buy Blog Forum Support

.deb bad quality

.deb bad quality

Postby andrew1979 on Tue Jan 29, 2013 7:45 pm

I receive an error when installing this (build 3007) on elementary OS (an ubuntu 12.04 derivative). It tells me that the .deb is “bad quality” as it “violates the quality standards”. Specifically, “The package doesn’t provide a valid Installed-Size control field. See Debian Policy 5.6.20.”
andrew1979
 
Posts: 2
Joined: Tue Jan 29, 2013 7:44 pm

Re: .deb bad quality

Postby superfake123 on Wed Jan 30, 2013 9:46 am

how are you trying to install it? have you tried from console

Code: Select all
sudo dpkg -i sublime-text_build-3007_amd64.deb
superfake123
 
Posts: 24
Joined: Wed Jun 27, 2012 2:24 pm

Re: .deb bad quality

Postby banzaimonkey on Wed Jan 30, 2013 10:46 am

FYI the error message is inert. The package installs anyway. Definitely a polish point, though.
banzaimonkey
 
Posts: 4
Joined: Sun Nov 06, 2011 12:08 am

Re: .deb bad quality

Postby nobleach on Wed Jan 30, 2013 3:35 pm

If you've previously used a PPA to install sublime, you may have to force the install using dpkg.

I just grabbed the tarball because I don't want to blow up my current installation.
nobleach
 
Posts: 48
Joined: Thu Jun 23, 2011 4:14 pm


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot] and 27 guests