Home Download Buy Blog Forum Support

Package control no longer works

Package control no longer works

Postby cyan on Sun Feb 03, 2013 6:37 pm

This seems to happen out of blue since a couple of weeks ago, and I haven't installed any new package for the past a couple of months.

At sublime (ver 2.0.1 Build 2217) startup, I see the following in the console:

Code: Select all
theme loaded
app ready
pre session restore time: 1.15291
using gamma: 2 (err: 4.79583)
SublimeLinter: python enabled (built in)
wrote startup cache, added files: 2 orphaned files: 0 total files: 267 cache hits: 265
startup time: 1.43048 (package setup was not run)
SublimeLinter: html disabled (tidy is not ready for HTML5)
SublimeLinter: css enabled (using JavaScriptCore)
loaded 1091 snippets
Package Control: Skipping automatic upgrade, last run at 2013-02-03 12:54:10, next run at 2013-02-03 13:54:10 or after
Traceback (most recent call last):
  File "./sublime_plugin.py", line 109, in create_window_commands
  File "./core.py", line 46, in __init__
    JsConsoleCommand.core = JSCore(self.console)
  File "./core.py", line 143, in __init__
    CommonJS.__init__(self)
  File "./jscontext/commonjs.py", line 29, in __init__
  File "./jscontext/commonjs.py", line 70, in execute
Boost.Python.ArgumentError: Python argument types in
    JSContext.eval(JSContext, unicode)
did not match C++ signature:
    eval(CContext {lvalue}, std::string source, std::string name='', int line=-1, int col=-1, boost::python::api::object precompiled=None)


And when I press cmd+shift+p (on Mac OS 10.6.8) and type in package control, there is only options for viewing its configs, all other options are gone! In addition, some package installed via package control before are not functioning correctly.

Any idea what is going on?
cyan
 
Posts: 3
Joined: Wed May 16, 2012 10:05 am

Re: Package control no longer works

Postby sublimator on Mon Feb 04, 2013 2:49 am

You got this installed ?

Seems like when sublime is trying to instantiate the plugin commands for any given window that plugin is causing a crash that stops other plugin commands from instantiating.

Try deleting that plugin somehow.
It is better to remain silent and be thought a fool, than to speak out and remove all doubt
sublimator
 
Posts: 649
Joined: Thu Mar 20, 2008 5:41 am

Re: Package control no longer works

Postby cyan on Mon Feb 04, 2013 1:50 pm

Looks like so. Given Package Control is not working, what other options do I have for uninstalling a package (installed via Package Control)?

Should I just delete the folder of relevant package inside the 'Packages' folder of ST2? Thanks.
cyan
 
Posts: 3
Joined: Wed May 16, 2012 10:05 am


Return to Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 13 guests