Home Download Buy Blog Forum Support

Serious UI lag on vertically oriented screens

Serious UI lag on vertically oriented screens

Postby rhemz on Wed Apr 07, 2010 8:35 pm

I've been experiencing some extreme UI lag when sublime (1.3) is running on a vertically oriented monitor in windowed mode. Keyboard and mouse actions are choppy and delayed about one second, menus are slow to draw, etc. Actions such as find in project do not seem to be affected. I have tried toggling different combinations of controls (minimap, tabs, toolbar) and views (single, double pane, etc) with no impact. Fullscreen mode works normally, it is just windowed mode that seems to have a problem. CPU usage shoots up to about 50% (up from 0) and the mouse lag continues for several seconds after the sublime window loses focus.

I have experienced this on two seperate machines, a 1.8Ghz core2 with 3GB memory & an ATI Radeon X1300 (work machine) w/ dx 9.0c running XP, and a 3ghz core2 w/ 4GB & NVidia 9800GX2 dx10 running Vista (home machine). Both experience the same issue (lag in windowed mode, fine in fullscreen mode).

Any ideas?
rhemz
 
Posts: 2
Joined: Sat Nov 14, 2009 2:47 am

Re: Serious UI lag on vertically oriented screens

Postby EJ12N on Fri Apr 09, 2010 1:27 pm

weird, I run sublime one of the sides monitors "vertically oriented ones" and never have issues... *I think* is most likely a graphics card issue. Update drivers? Try running sublime in opengl instead of DX.
http://www.sublimetext.com/docs/command-line
EJ12N
 
Posts: 281
Joined: Tue Apr 21, 2009 5:23 pm


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot], Vohm, Yahoo [Bot] and 36 guests