Home Download Buy Blog Forum Support

ST3: find won't find stuff (even when its right there!)

ST3: find won't find stuff (even when its right there!)

Postby sameersbn on Fri Feb 15, 2013 1:10 pm

Hi,

I am using ST3 on Ubuntu 12.10 (32 bit), I have noticed that sometimes sublime text will not be able to find text if when it exists in the text document.
It starts working only when i find that text, select it and do ctrl+f. This happens every once in a while, other times its fine.

Considering moving back to ST2.
I am new to ST and have not used ST2 much itself. Hoping that ST2 will behave itself.

Regards
~Sameer
sameersbn
 
Posts: 6
Joined: Wed Feb 13, 2013 5:32 am

Re: ST3: find won't find stuff (even when its right there!)

Postby mark4 on Sat Feb 16, 2013 8:45 pm

i saw this last week and thought it was me doing something wrong.

press ^f and enter search string and hit enter and sometimes get string not found. when this happens, go to somwhere in same file that contains the string, double click it and press ^f and now it finds them all.
mark4
 
Posts: 97
Joined: Sat Feb 11, 2012 3:33 am

Re: ST3: find won't find stuff (even when its right there!)

Postby sameersbn on Mon Feb 18, 2013 6:40 am

I have switched to ST2, and the problem exists there as well.
I have no idea how to reproduce it. It just happens when it happens.
sameersbn
 
Posts: 6
Joined: Wed Feb 13, 2013 5:32 am

Re: ST3: find won't find stuff (even when its right there!)

Postby quarnster on Mon Feb 18, 2013 9:44 am

Is "in selection" checked?
quarnster
 
Posts: 389
Joined: Tue Nov 29, 2011 11:34 am

Re: ST3: find won't find stuff (even when its right there!)

Postby sameersbn on Mon Feb 18, 2013 1:01 pm

I think i figured what the problem was.
Not an issue with ST.

Actually what seemed to happen is, when i wanted to press 'ctrl + f' and then 'enter' to find the first instance of the string. I accidentally pressed 'ctrl + enter' which caused the find bar to take a new line character. The text that was entered in the find bar was essentially out of view because of the new line character, due to which i would enter the search text again and sublime text would not find that text which ended up being "search string\nsearch string".

Checkout the below screenshot, you will notice some portion of previous line in the search box (which i thought was an drawing issue).
http://screencloud.net/v/enVt

Thanks and Regards
~Sameer
sameersbn
 
Posts: 6
Joined: Wed Feb 13, 2013 5:32 am


Return to Technical Support

Who is online

Users browsing this forum: Vohm, Yahoo [Bot] and 31 guests