Home Download Buy Blog Forum Support

SublimeLinter user settings for jslint

SublimeLinter user settings for jslint

Postby taylorp0994 on Sun Mar 03, 2013 2:24 pm

Hi,

I'm wanting to implement jslint in the SublimeLinter package on my Windows machine.
I'm running Windows 7 64-bit and I have nodejs installed under "C:/Program Files/nodejs/node.js".
When I attempt to save the necessary user settings in "SublimeLinter.sublime-settings" it is giving an error every time.

Here is what I have in the file...
Code: Select all
    "sublimelinter_executable_map":
    {
       "jslint": "C:/Program Files/nodejs/node.js"
    },


and here is a screenshot of the error...
Untitled.png
Error screenshot
Untitled.png (20 KiB) Viewed 863 times
taylorp0994
 
Posts: 2
Joined: Sun Mar 03, 2013 2:17 pm

Re: SublimeLinter user settings for jslint

Postby iamntz on Sun Mar 03, 2013 3:55 pm

1) make sure you wrap everything in {}
2) double check your trailing commas.
3) http://jsonlint.com/

Code: Select all
{
    "sublimelinter_executable_map":
    {
       "jslint": "C:/Program Files/nodejs/node.js"
    }
}


Should work better.
iamntz
 
Posts: 898
Joined: Fri Apr 29, 2011 8:52 am
Location: Romania

Re: SublimeLinter user settings for jslint

Postby taylorp0994 on Sun Mar 03, 2013 7:42 pm

That fixed it right up.
After adding brackets and removing the trailing comma everything went back to normal.

Thank you for the quick response. :)
taylorp0994
 
Posts: 2
Joined: Sun Mar 03, 2013 2:17 pm


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot], Google [Bot] and 25 guests