Home Download Buy Blog Forum Support

ST3: Cannot edit Key Binding - Default

ST3: Cannot edit Key Binding - Default

Postby gfedz on Fri Mar 08, 2013 5:27 pm

I have ST3 Build 3012 installed. When I go to Preference > Key Bindings - Default, the file opens up but I am unable to manipulate the file at all. I'm trying to change a few of the bindings around to match what I have on my work PC but the file seems locked. My work PC is ST2 Build 2217 and works just fine. Any ideas on what's going on?
gfedz
 
Posts: 2
Joined: Thu Jan 24, 2013 7:29 pm
Location: Minnesota

Re: ST3: Cannot edit Key Binding - Default

Postby facelessuser on Fri Mar 08, 2013 6:07 pm

You should never edit the defaults because they are the default. View the default to see what the settings are, and if you want to change them, add/change them in your User version. Every time Sublime Text updates, it overwrites the defaults so you would always be having to change things back to the way you like them after upgrades. ST3 now has the defaults packaged in zip files, so there is no way to edit them save extracting the file, editing it, and repacking...so just edit your user variant.
facelessuser
 
Posts: 1544
Joined: Tue Apr 05, 2011 7:38 pm

Re: ST3: Cannot edit Key Binding - Default

Postby gfedz on Fri Mar 08, 2013 6:24 pm

I suppose that would make sense in how new builds would overwrite my changes. Thank you for the reply.
gfedz
 
Posts: 2
Joined: Thu Jan 24, 2013 7:29 pm
Location: Minnesota

Re: ST3: Cannot edit Key Binding - Default

Postby asafebgi on Wed Feb 12, 2014 3:00 am

I'd like to disable the function key bindings -- ie, F1, F2, F3 -- Removing the entries from the Default key bindings would normally work -- Except now the default bindings aren't editable -- Is there some way to disable sublime from binding the function keys? I use them with auto-hot key. -- Thanks
asafebgi
 
Posts: 2
Joined: Wed Feb 12, 2014 2:57 am

Re: ST3: Cannot edit Key Binding - Default

Postby skuroda on Wed Feb 12, 2014 6:10 am

Open the default key bindings using https://github.com/skuroda/PackageResourceViewer. Edit the file and save it as you would normally. This will create an override file in the proper location.Alternatively, you can create entries in your user key bindings for the function keys with some command that does not exist.
skuroda
 
Posts: 676
Joined: Fri Oct 05, 2012 8:11 am

Re: ST3: Cannot edit Key Binding - Default

Postby subhaze on Wed Feb 12, 2014 6:18 am

You could add `"command": "noop"`to the bindings you want to do nothing in your User file. That way you don't have to worry about an update overwriting your changes.
subhaze
 
Posts: 211
Joined: Tue Apr 09, 2013 3:22 am

Re: ST3: Cannot edit Key Binding - Default

Postby asafebgi on Wed Feb 12, 2014 9:24 am

Great thanks, both noop and package resource editors approaches worked in disabling the function keys.

(BTW, the issue was sublime being run in as administrator in Windows 7 -- AHK doesn't intercept function key calls to programs running in admin)
asafebgi
 
Posts: 2
Joined: Wed Feb 12, 2014 2:57 am


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot] and 19 guests