Home Download Buy Blog Forum Support

[Bug] Windows-1254 Charset Problem

[Bug] Windows-1254 Charset Problem

Postby firat on Mon Jul 12, 2010 7:03 am

well.. sorry for my english.

I need to test sublime before have a licence. But there is a one big problem.

Sublime doesnt read windows-1254 context properly.

E-texteditor

Image

Sublime
Image

And a switch charset to active context, that may really helpfull for me. Thanks.
firat
 
Posts: 1
Joined: Mon Jul 12, 2010 6:55 am

Re: [Bug] Windows-1254 Charset Problem

Postby jps on Sun Aug 01, 2010 3:26 am

Did you open the file using the menu item "File/Open with encoding/Open with Turkish (Windows 1254)"?
jps
Site Admin
 
Posts: 3062
Joined: Wed Mar 19, 2008 12:33 pm

Re: [Bug] Windows-1254 Charset Problem

Postby hctopcu on Wed Jul 11, 2012 9:35 am

I usually have the same issue.
I have different files in different encodings. Can not Sublime detect it upon open?
hctopcu
 
Posts: 1
Joined: Wed Jul 11, 2012 9:34 am

Re: [Bug] Windows-1254 Charset Problem

Postby bizoo on Wed Jul 11, 2012 9:51 am

hctopcu wrote:I usually have the same issue.
I have different files in different encodings. Can not Sublime detect it upon open?

There's no reliable way to detect the encoding of a file, except when a BOM is present (UTF8, UTF16).
There's a plugin available (https://github.com/SublimeText/EncodingHelper) that guess the encoding of a file when opening it. Didn't try it.
bizoo
 
Posts: 874
Joined: Wed Dec 08, 2010 6:53 am
Location: Switzerland


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 23 guests