Home Download Buy Blog Forum Support

no plugin functionality in 3036

no plugin functionality in 3036

Postby billehunt on Tue Jun 04, 2013 3:39 am

Yuck. Just updated to 3036, and now when ST3 comes up, it pauses a second or two and says that plugin functionality will not be available until ST3 has been restarted. Restarting does not resolve.

The console has no errors from any of the loaded components, just the final error (below).

Worst of all, I've searched around and can't find where I can download previous revs, so I can't back out the latest upgrade.

Help, please!

Code: Select all
DPI scale: 1
startup, version: 3036 windows x64 channel: dev
executable: /C/Program Files/Sublime Text 3/sublime_text.exe
working dir: /C/Program Files/Sublime Text 3
packages path: /C/Users/Bill/AppData/Roaming/Sublime Text 3/Packages
state path: /C/Users/Bill/AppData/Roaming/Sublime Text 3/Local
hardware concurrency: 8
zip path: /C/Program Files/Sublime Text 3/Packages
zip path: /C/Users/Bill/AppData/Roaming/Sublime Text 3/Installed Packages
found 9 files for base name Default.sublime-keymap
found 1 files for base name Default.sublime-mousemap
found 7 files for base name Main.sublime-menu
loading bindings
loading pointer bindings
found 1 files for base name Default.sublime-theme
theme loaded
app ready
startup cache, total files: 170 cache hits: 170
pre session restore time: 0.213321
startup time: 0.310321
first paint time: 0.315321
launching: /C/Program Files/Sublime Text 3/plugin_host.exe
reloading plugin Default.block
reloading plugin Default.comment
reloading plugin Default.copy_path
reloading plugin Default.delete_word
reloading plugin Default.detect_indentation
reloading plugin Default.duplicate_line
reloading plugin Default.echo
reloading plugin Default.exec
reloading plugin Default.fold
reloading plugin Default.font
reloading plugin Default.goto_line
reloading plugin Default.history_list
reloading plugin Default.indentation
reloading plugin Default.kill_ring
reloading plugin Default.mark
reloading plugin Default.new_templates
reloading plugin Default.open_file_settings
reloading plugin Default.open_in_browser
reloading plugin Default.pane
reloading plugin Default.paragraph
reloading plugin Default.paste_from_history
reloading plugin Default.save_on_focus_lost
reloading plugin Default.scroll
reloading plugin Default.set_unsaved_view_name
reloading plugin Default.side_bar
reloading plugin Default.sort
reloading plugin Default.swap_line
reloading plugin Default.switch_file
reloading plugin Default.symbol
reloading plugin Default.transform
reloading plugin Default.transpose
reloading plugin Default.trim_trailing_white_space
reloading plugin CSS.css_completions
reloading plugin Diff.diff
reloading plugin HTML.encode_html_entities
reloading plugin HTML.html_completions
reloading plugin Emmet.emmet-plugin
reloading plugin Origami.origami
reloading plugin Package Control.Package Control
loaded 837 snippets
reloading plugin Pretty JSON.PrettyJson
reloading plugin SublimeLinter.SublimeLinter
imported capp_lint
SublimeLinter: C loaded
SublimeLinter: CoffeeScript loaded
SublimeLinter: CSS loaded
SublimeLinter: c_cpplint loaded
SublimeLinter: Git Commit Message loaded
SublimeLinter: Ruby Haml loaded
SublimeLinter: HTML loaded
SublimeLinter: Java loaded
SublimeLinter: JavaScript loaded
SublimeLinter: Lua loaded
SublimeLinter: Annotations loaded
SublimeLinter: Objective-J loaded
SublimeLinter: Perl loaded
SublimeLinter: PHP loaded
SublimeLinter: Puppet loaded
SublimeLinter: Python loaded
SublimeLinter: Ruby loaded
SublimeLinter: pylint loaded
SublimeLinter: XML loaded
reloading plugin User.PhpUnit
reloading plugin User.TortoiseGit
plugins loaded
error: plugin_host has exited unexpectedly, plugin functionality won't be available until Sublime Text has been restarted
billehunt
 
Posts: 7
Joined: Tue Jan 31, 2012 12:51 am

Re: no plugin functionality in 3036

Postby Lemon on Tue Jun 04, 2013 3:50 am

People have been posting about this in the build 3036 thread.

For me removing the BracketHighlighter plugin solved the problem.
For others removing Emmet solved the problem.

I'm sure it will be fixed soon but until then you can just copy a link from one of the latest downloads and manually change it to get one of the previous versions.

For example for me the Windows 64 bit setup version of 3035 is:
http://c758482.r82.cf2.rackcdn.com/Subl ... 0Setup.exe
Lemon
 
Posts: 27
Joined: Wed Jul 11, 2012 12:49 pm

Re: no plugin functionality in 3036

Postby billehunt on Tue Jun 04, 2013 3:55 am

Thanks! I'll reply in that thread. (sorry - didn't know there were dedicated branch threads, and I searched for the error message with no luck)
billehunt
 
Posts: 7
Joined: Tue Jan 31, 2012 12:51 am

Re: no plugin functionality in 3036

Postby billehunt on Sat Jun 08, 2013 9:40 pm

confirming this issue is resolved in 3037
billehunt
 
Posts: 7
Joined: Tue Jan 31, 2012 12:51 am


Return to Technical Support

Who is online

Users browsing this forum: No registered users and 8 guests