Home Download Buy Blog Forum Support

[SOLVED] Missing Syntax File Errors

[SOLVED] Missing Syntax File Errors

Postby layne on Mon Jul 01, 2013 9:29 pm

After resetting Sublime Text 3 get the following two issues in the console:

Code: Select all
error: Error loading syntax file "Packages/Text/Plain text.tmLanguage": Unable to open Packages/Text/Plain text.tmLanguage
error: Error loading syntax file "Packages/AAAPackageDev/Support/Sublime Text Build System.tmLanguage": Unable to open Packages/AAAPackageDev/Support/Sublime Text Build System.tmLanguage

First error was right after the first start.
The last one just popped up in one project. I tried to install the package through Package Control and remove it. But the error still exists.

Can someone help me or give some hints?
Last edited by layne on Wed Jan 29, 2014 11:45 pm, edited 2 times in total.
// my Blog //
layne
 
Posts: 39
Joined: Tue Jan 04, 2011 3:00 pm
Location: NRW // GER

Re: Missing

Postby weslly on Mon Jul 01, 2013 9:44 pm

This is the FAQ for ST2, try this one:
http://www.sublimetext.com/docs/3/revert.html
weslly
 
Posts: 202
Joined: Sun Aug 28, 2011 3:57 am
Location: Brazil

Re: Missing Syntax File Errors

Postby layne on Mon Jul 01, 2013 9:54 pm

Thanks, but's the same way. Just Sublime Text 3 instead of Sublime Text 2 Folder inside Application Support on Mac OS X.
(I'm running Mac OS X and 3047)
// my Blog //
layne
 
Posts: 39
Joined: Tue Jan 04, 2011 3:00 pm
Location: NRW // GER

Re: Missing Syntax File Errors

Postby cartland on Tue Aug 13, 2013 9:57 am

I have found this and numerous other "glitches" are due to problems in the Local/Session.sublime_session file.

Either edit the file or just delete it. It may also help to remove the Cache and Index folders.
cartland
 
Posts: 2
Joined: Tue Aug 13, 2013 9:52 am

Re: Missing Syntax File Errors

Postby layne on Wed Jan 29, 2014 11:45 pm

Just want to deliver the answer. I was just to stupid ... like often.

I just disabled the package "Text" from SB Core.
// my Blog //
layne
 
Posts: 39
Joined: Tue Jan 04, 2011 3:00 pm
Location: NRW // GER


Return to Technical Support

Who is online

Users browsing this forum: No registered users and 20 guests