Home Download Buy Blog Forum Support

BUG: Build system eats some of the output (and other issues)

BUG: Build system eats some of the output (and other issues)

Postby bobef on Sat Jul 13, 2013 10:15 am

Some serious problems with the capturing of the output of build systems. This is ST 2.0.2 Win7 x64 Home Premium.

I have created a simple build system that executes run.bat which I can put some stuff in to execute my Node.js script.

The build system looks like this. It captures all files which start with C:\
Code: Select all
{
   "cmd": ["run.bat"],
   "file_regex": "(C:\\\\.+?):([0-9]+)"
}


There are two problems. First, when I press F4, it walks the matched files backwards. I.e. F4 does nothing because it starts from the end. I need to press Shift+F4 and it starts from the last file and I need to press this million times to get to the first, losing my way in the process.

The second problem, even worse, is that lot of the output is not shown in the console at all. In my node script I have some console.log() calls that I use for debugging.
Most of them are missing in the output panel in Sublime. When I run my run.bat from cmd.exe all is fine. Check the screenshot here https://docs.google.com/file/d/0ByZeCc6 ... sp=sharing .
Last edited by bobef on Mon Jul 22, 2013 8:56 am, edited 1 time in total.
bobef
 
Posts: 26
Joined: Tue Nov 20, 2012 7:16 am

Re: ST2: Build system eats some of the output (and other issues)

Postby bobef on Mon Jul 22, 2013 8:55 am

One more related problem: When you double click a file in the output panel to go its location the focus remains on the output panel, i.e. the source panel is not activated and it doesn't show any cursor so you actually need to look where the line number you need is. Although it is scrolled in the view, without cursor you can't see it.
bobef
 
Posts: 26
Joined: Tue Nov 20, 2012 7:16 am

Re: BUG: Build system eats some of the output (and other issues)

Postby bobef on Tue Jul 23, 2013 6:05 am

One more related problem: Sublime's technical support sucks. Yes, I know I bought it "as is" and it is still great, but your support sucks. I've posted major bug with one of the important core functionalities of Sublime Text 10 days ago and there is no response whatsoever. You should have some sort of support and have it in a place where people shouldn't be able to post about problems with their plugins etc...
bobef
 
Posts: 26
Joined: Tue Nov 20, 2012 7:16 am


Return to Technical Support

Who is online

Users browsing this forum: Clams, Exabot [Bot] and 16 guests