Home Download Buy Blog Forum Support

UTF-8 encoding doesn't work.

UTF-8 encoding doesn't work.

Postby AnDer on Tue Jul 16, 2013 1:51 pm

I'm learning Java and in OS X, but with the latest version of ST, 2.0.2, and the beta build, UTF-8 ASCII encoding doesn't work in ST Builder.
If I insert char "è" o something like this (also in a comments!!), it says "Unmappable character for encoding ASCII", replacing "è" with "??".
I also click on "Reopen with Encoding" > "UTF-8", but nothing change.
Okay, I can compile it in Terminal, but it is slightly annoying.
What can I do? In che older version (2.0.0 or 2.0.1), it didn't returns this error.

Thank you.
AnDer
 
Posts: 6
Joined: Tue Jul 16, 2013 1:43 pm

Re: UTF-8 encoding doesn't work.

Postby AnDer on Sun Jul 21, 2013 9:13 pm

UP! Someone could help me?

Image
AnDer
 
Posts: 6
Joined: Tue Jul 16, 2013 1:43 pm

Re: UTF-8 encoding doesn't work.

Postby AnDer on Sat Jul 27, 2013 12:10 am

UP! I descovered also that if there is a char like "è", the builder does not find other errors that Terminal get. :/
AnDer
 
Posts: 6
Joined: Tue Jul 16, 2013 1:43 pm

Re: UTF-8 encoding doesn't work.

Postby weslly on Sat Jul 27, 2013 1:31 am

Have you tried creating a new build system for Java using the encoding parameter?
weslly
 
Posts: 198
Joined: Sun Aug 28, 2011 3:57 am
Location: Brazil

Re: UTF-8 encoding doesn't work.

Postby AnDer on Sat Jul 27, 2013 2:10 am

Thanks for the answer
I wrote in new file:

{
"cmd": ["java", "encoding ISO-8859"]
}

but when I try to compile, it says:
"Error: impossibile to find or load main class encoding ISO-8859"

(I tried also with ISO-8859-1, how there is wrote in the site you linked me)

What I must do?

EDIT:

I remember that is "javac" and not "java". Now it says:

"javac: invalid flag: -encoding: ISO-8859-1
Usage: javac <options> <source files>
use -help for a list of possible options"

what i must to do? :|
AnDer
 
Posts: 6
Joined: Tue Jul 16, 2013 1:43 pm

Re: UTF-8 encoding doesn't work.

Postby weslly on Sat Jul 27, 2013 5:18 pm

AnDer wrote:"javac: invalid flag: -encoding: ISO-8859-1
Usage: javac <options> <source files>
use -help for a list of possible options"

what i must to do? :|


You don't need to use a colon between the flag and the value.
weslly
 
Posts: 198
Joined: Sun Aug 28, 2011 3:57 am
Location: Brazil

Re: UTF-8 encoding doesn't work.

Postby AnDer on Sat Jul 27, 2013 6:25 pm

weslly wrote:
AnDer wrote:"javac: invalid flag: -encoding: ISO-8859-1
Usage: javac <options> <source files>
use -help for a list of possible options"

what i must to do? :|


You don't need to use a colon between the flag and the value.


I delete it, but nothing change.

I put also "-" before encoding, but nothing.

{
"cmd": ["javac", "encoding ISO-8859-1"],
}

javac: invalid flag: encoding ISO-8859-1
Usage: javac <options> <source files>
use -help for a list of possible options
[Finished in 0.1s with exit code 2]
AnDer
 
Posts: 6
Joined: Tue Jul 16, 2013 1:43 pm

Re: UTF-8 encoding doesn't work.

Postby AnDer on Sat Aug 10, 2013 8:40 pm

UP, someone found a solution? :/
AnDer
 
Posts: 6
Joined: Tue Jul 16, 2013 1:43 pm

Re: UTF-8 encoding doesn't work.

Postby Lemon on Sun Aug 11, 2013 3:21 am

Have you tried:
Code: Select all
"cmd": ["javac", "encoding", "ISO-8859-1"]
Lemon
 
Posts: 27
Joined: Wed Jul 11, 2012 12:49 pm

Re: UTF-8 encoding doesn't work.

Postby bizoo on Mon Aug 12, 2013 10:40 am

I suppose it must be:
Code: Select all
"cmd": ["javac", "-encoding", "ISO-8859-1"]

What's the content of your console after you run the build ?
The executed command must be printed on it.

In addition, I warmly recommend you to use -encoding UTF-8 and forget about custom encoding.
bizoo
 
Posts: 859
Joined: Wed Dec 08, 2010 6:53 am
Location: Switzerland


Return to Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 16 guests