Home Download Buy Blog Forum Support

Nginx won't serve static files only when saved by Sublime?

Nginx won't serve static files only when saved by Sublime?

Postby keogh on Tue Jul 30, 2013 6:00 pm

Hi Guys,

Got a very strange problem happening that I can't solve, Ive never seen it before.

I work on a Windows 8 x64 PC and I have a VirtualBox Ubuntu 13.04 server that is running Nginx 1.5.2 + PHP5-FPM and all works fine.

However, whenever I save a static file (css/html etc) in Sublime text 2.0.2 on my Windows x64 machine to my guest Ubuntu 13.04, if I refresh the page in my browser I get a nginx 500 Internal Server Error, hit refresh again and all is fine and dandy.

It happens every single change I make to a static file, and the nginx error log doesn't so much apart from the fact the file is temporarily unavailable?

But here is the strange thing, if I save static files from my Windows 8 machine via Notepad++ I get no issues whatsoever? It will load all static files straight away, so it appears that Sublime must be doing sumin to the file?

My initial thoughts where EOL or Encoding, and after looking it appears that Sublime isn't saving them as UNIX and UTF-8 regardless of my setting? It seems to be ANSI all the time? However, even if I save a file as Dos/Windows and ANSI with Notepad++ it still serves it on nginx.

Anyone have any ideas, this is quite annoying having to refresh twice?

ta
keogh
 
Posts: 7
Joined: Fri Jan 18, 2013 11:54 am

Re: Nginx won't serve static files only when saved by Sublime?

Postby keogh on Tue Jul 30, 2013 10:05 pm

This can be ignored now, I've found the issue.

It was Samba locking the file upon save, adding:

Code: Select all
oplocks = no


To my smb.conf fix the issue.

Still kinda odd this only occurred in Sublime... although it did happen once or twice in Notepad++ but very rarely.
keogh
 
Posts: 7
Joined: Fri Jan 18, 2013 11:54 am


Return to Technical Support

Who is online

Users browsing this forum: No registered users and 26 guests