Home Download Buy Blog Forum Support

Un-indent keyboard shortcut doesn't work

Un-indent keyboard shortcut doesn't work

Postby jonathanconway on Sun Nov 28, 2010 6:23 am

I can click 'Edit --> Unindent' and the current line will be out-dented.

But if I press the key combination:

SHIFT + TAB

Nothing happens.

This is basic functionality I would expect from any program claiming to be a "programmer's" text editor.

Cheers,
Jonathan
jonathanconway
 
Posts: 1
Joined: Sun Nov 28, 2010 6:20 am

Re: Un-indent keyboard shortcut doesn't work

Postby jhawk28 on Sun Nov 28, 2010 6:03 pm

Here is the reason...Preferences -> Default Key Bindings

Code: Select all
<binding key="shift+tab" command="noop"/>
<binding key="shift+tab" command="unindent">
   <context name="newlineInSelection" value="true"/>
</binding>
<binding key="shift+tab" command="prevField">
   <context name="hasPrevField" value="true"/>
</binding>


If you select code, it will unindent as expected.
jhawk28
 
Posts: 26
Joined: Sat Jun 13, 2009 2:17 pm


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 31 guests