Home Download Buy Blog Forum Support

Save closes last opened tab

Save closes last opened tab

Postby nanos on Mon Sep 09, 2013 12:09 pm

Hi,

I'm currently using version 2.0.2 on Windows 7 and on every 'Save' it closes my last opened file, which is absolutely hugely annoying!

Yesterday it was fine, and when I came back to my computer this morning it's doing this.

Can anybody help me sorting this out?

Any help would be greatly appreciated!
nanos
 
Posts: 5
Joined: Mon Sep 09, 2013 12:07 pm

Re: Save closes last opened tab

Postby nanos on Tue Sep 10, 2013 2:43 pm

Hi,

I'm sorry to be a bit of pain here, but this is really hugely annoying :( Does anybody have any suggestion on this? I would really appreciate any help.

Thanks!
nanos
 
Posts: 5
Joined: Mon Sep 09, 2013 12:07 pm

Re: Save closes last opened tab

Postby iamntz on Tue Sep 10, 2013 3:16 pm

iamntz
 
Posts: 917
Joined: Fri Apr 29, 2011 8:52 am
Location: Romania

Re: Save closes last opened tab

Postby nanos on Tue Sep 10, 2013 3:48 pm

Hi,

thank you for your answer!

I just tried that and it did work. However, I'd need to re-install all my settings packages which would probably take days. Do you have anymore ideas how to properly track down the the change that is causing this issue?

Thanks!
nanos
 
Posts: 5
Joined: Mon Sep 09, 2013 12:07 pm

Re: Save closes last opened tab

Postby nanos on Tue Sep 10, 2013 4:27 pm

I just learnt that I can log all commands in the console, and when doing this I get the following output:

Code: Select all
command: save
Writing file /C/path/to/file.cfm with encoding UTF-8


So, nothing extraordinary as far as I can see.

Also, following the behaviour for the last day or so, it does seem a lot more random than first described: It's not just the last opened file that closes (although it sometimes is) but it also frequently happens that all files except the currently active one get closed. Anything in between these two extremes is possible, really, and I haven't been able to detect and order in what is getting closed and what isn't.

Finally, I noticed that it seems that the file(s) to be closed receive focus for the fraction of a second before actually closing. This is hard to verify as it happens too quickly for the buffer to actually update, but the tab representing the file changes colour as if it was active for the fraction of a second before disappearing, and the buffer flashes quickly. As I said: this is so very fast that I wouldn't absolutely say it happens, but it seems to be the case.

As I said, any help would really be greatly appreciated, as I spent quite some time setting my installation up, and therefore don't really want to start again from scratch ...

Thanks for taking the time to read this!
nanos
 
Posts: 5
Joined: Mon Sep 09, 2013 12:07 pm

Re: Save closes last opened tab

Postby iamntz on Tue Sep 10, 2013 4:48 pm

Well, for start, you could add only User folder and see if there is a problem with your settings or with an existing package.

Then start re-adding packages; e.g. add batch of 5 packages, check if the problem exists. If not, add more 5 packages. If yes, try to remove one by one packages you just add and so on.
iamntz
 
Posts: 917
Joined: Fri Apr 29, 2011 8:52 am
Location: Romania

Re: Save closes last opened tab

Postby nanos on Wed Sep 11, 2013 9:43 am

Hi,

you are my hero! Truely, should've thougt of that myself - after all I do debugging for a living ^^ - but sometimes I'm just plain stupid ..

Anyway, turns out the culprit was a plugin called 'Tidy Tabs'. From the readme:

With this plugin, a simple keystroke `ctrl + alt + w` will close all tabs whose file has not been modified in the last 30 minutes (to change this interval, see Preferences > Packages > TidyTabs > Settings).
You can also configure the plugin to automatically close old tabs each time you save a file. To enable this, go to Preferences > Packages > TidyTabs > Settings and set `tidytabs_run_on_post_save` to true.


Well, I've had that plugin for ages and it always worked, and 'tidytabs_run_on_post_save' was set to false, but it still closed the tabs. Uninstalling it sorted it, and I'll have to have a look whether I want to find an altertnative.

Thanks for your help!
nanos
 
Posts: 5
Joined: Mon Sep 09, 2013 12:07 pm


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot], Google [Bot], Yahoo [Bot] and 22 guests