Home Download Buy Blog Forum Support

Disabling autocomplete (directions aren't working)

Disabling autocomplete (directions aren't working)

Postby hetchjay on Wed Sep 18, 2013 4:32 pm

I have a bunch of old hand-written HTML code that I work on and autocomplete is pretty annoying since it tries to close a bunch of unclosed but unimportant tags, e.g. </li>.

Here's what I tried:
1. Used the sublime.packages_path() command to find packages folder (in Windows)
2. Navigated to ...AppData\Roaming\Sublime Text 3\Packages\User, where indeed I see a bunch of settings files.
3. Created an HTML.sublime-settings file which contains exactly the text:

{
"auto_complete": false
}

This did nothing, so I decided to disable auto-complete altogether.
4. To do this, I edited ...AppData\Roaming\Sublime Text 3\Packages\User\Preferences.sublime-settings, which now reads exactly:

{
"font_size": 10,
"auto_complete": false,
"ignored_packages":
[
"Vintage"
]
}

This also did not stop autocomplete (even after restarting sublime)

5. Looked again at the official autocomplete page at http://www.sublimetext.com/docs/3/auto_complete.html. This suggests using "Preferences/File Settings - User", but Under the preferences tab, there is no "File Settings - User" tab, only "Settings - User" -- and that just takes me to that file I edited in step 4 (and I can see that it includes the show "auto-complete": false line, with no apparent effect)
hetchjay
 
Posts: 1
Joined: Wed Sep 18, 2013 4:26 pm

Re: Disabling autocomplete (directions aren't working)

Postby Loopy on Fri Feb 13, 2015 3:07 pm

I'm having the same problem, but my issue is that when I get to the end of a line, it suggests all tags and when I press [ENTER], it inserts and A tag because that's the first thing in the list.

At the end of a line, when I press enter, I want to go to a new line, obviously.

I tried disabling autocomplete in both the default and user preferences to no avail, even after restarting the application.

Thanks, in advance, for any help which can be provided.
Loopy
 
Posts: 3
Joined: Fri Feb 13, 2015 3:04 pm

Re: Disabling autocomplete (directions aren't working)

Postby Loopy on Tue Feb 17, 2015 5:30 pm

It is also doing this when I try to tab out on a new line. What the heck?

It literally will create a string of empty A tags when I tab multiple times on an empty line.
Loopy
 
Posts: 3
Joined: Fri Feb 13, 2015 3:04 pm

Re: Disabling autocomplete (directions aren't working)

Postby Loopy on Mon May 04, 2015 7:14 pm

Is there anybody out there?
Loopy
 
Posts: 3
Joined: Fri Feb 13, 2015 3:04 pm

Re: Disabling autocomplete (directions aren't working)

Postby adzenith on Tue May 05, 2015 3:40 pm

Sounds like you're using a plugin.
adzenith
 
Posts: 1350
Joined: Mon Oct 19, 2009 9:12 pm


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot], Mooseous and 18 guests