Home Download Buy Blog Forum Support

Can't startup Sublime after OS X Mavericks upgrade

Can't startup Sublime after OS X Mavericks upgrade

Postby jellithorpe on Sat Oct 26, 2013 1:41 am

Hi,

I just upgraded to OS X Mavericks and now when I try to start SublimeText 2, I get the following error:

Unable to run package setup:

Traceback (most recent call last):
File "./PackageSetup.py", line 165, in upgrade
upgradePackage(pkg, pristinedir, datadir, backupdir)
File "./PackageSetup.py", line 158, in upgradePackage
os.path.join(backupdir, base), inhibitOverwrite)
File "./PackageSetup.py", line 90, in upgradeArchive
writeFile(fname, newar.read(f))
File "./PackageSetup.py", line 18, in writeFile
with open(fname, 'wb') as fo:
IOError: [Errno 2] No such file or directory: u'/Packages/ActionScript/ActionScript.tmLanguage'

As you can see from the error, it can't load the file. The strange thing is the directory looks wrong. I expected the directory to be: /Users/jellithorpe/Library/Application Support/Sublime Text 2/Packages/ActionScript/ActionScript.tmLanguage, which is where the files actually are. However, the leading "/Users/jellithorpe/Library/Application Support/Sublime Text 2" is missing and I'm suspecting it's because of the OS X Mavericks upgrade.

Note that I'm running Sublime Text 2 build 2221 on a MacBook Pro.

Has anyone seen this before?

Thanks,
John
jellithorpe
 
Posts: 1
Joined: Sat Oct 26, 2013 1:32 am

Return to Technical Support

Who is online

Users browsing this forum: No registered users and 14 guests