Home Download Buy Blog Forum Support

Sublime stopped loading package?

Sublime stopped loading package?

Postby mcbsys on Sat Oct 26, 2013 3:01 am

Hi,

I'm using Sublime Text 2.0.2 under Ubuntu 12.04.3 LTS under VirtualBox. Python version is 2.7.3. I keep Ubuntu updated with the latest recommend updates. There must have been a kernel update a couple days ago because I had to re-install the VirtualBox Guest Additions.

A couple years ago, I installed a plugin/package called Sublime-Text-2-Ruby-Tests (https://github.com/maltize/sublime-text-2-ruby-tests). Until a few days ago, I could start an RSpec test in Ruby on Rails by clicking on Ctrl-Shift-R. Now, that doesn't work; nothing happens.

When I turn on command logging in the console and press Ctrl-Shft-R, nothing is recorded.

The package is deployed by copying it directly from GitHub to ~/.config/sublime-text-2/Packages/RubyTest. The files are still there.

When I start Sublime, the console lists a bunch of plugins that it is "reloading." The package's Python file, run_ruby_test.py, is not one of them. Is it supposed to be?

I don't know where to start. Did something get clobbered by the most recent Ubuntu updates? Is there something else that could cause a package to stop loading?

Thanks,

Mark
mcbsys
 
Posts: 5
Joined: Fri May 25, 2012 11:16 pm

Re: Sublime stopped loading package?

Postby adzenith on Sun Oct 27, 2013 7:56 pm

See if it's listed as ignored in your user settings? Try to reinstall it?
adzenith
 
Posts: 1213
Joined: Mon Oct 19, 2009 9:12 pm

Re: Sublime stopped loading package?

Postby mcbsys on Mon Oct 28, 2013 11:11 pm

Thank you! I didn't even know there was such a thing as an ignored_packages list.

Not sure how, but my tiny collection of four packages were all ignored. Sometimes I forget to close Sublime and Ctrl-C kill it from the console where I started it. Emptying the ignored_packages list fixed it. If anyone else is wondering where to find ignored_packages: it's a hard-coded array in the Packages/User/Preferences.sublime-settings file (to open in Sublime, choose Preferences > Settings - User). Just remove everything inside the array's [square brackets].

References:

http://stackoverflow.com/questions/1817 ... es-ignored

https://github.com/wbond/sublime_packag ... issues/558

Mark Berry
MCB Systems
mcbsys
 
Posts: 5
Joined: Fri May 25, 2012 11:16 pm


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot], JerseyMilker and 22 guests