Home Download Buy Blog Forum Support

Scrolling not working on Surface Pro 2

Scrolling not working on Surface Pro 2

Postby JoeHazzers on Sun Nov 24, 2013 5:10 pm

I'm using the latest sublime text 3 build (3047) and I'm unable to scroll at all using two fingers on the Type Cover touchpad on my Surface Pro 2 running windows 8.1.

The scroll works fine in other applications, and the problem persists after rebooting. Further to this, it seems that Sublime Text 3 doesn't properly support touch input on Windows 8 (as sliding my finger vertically over the text selects it instead of scrolls).

Are there any solutions to these two problems?
JoeHazzers
 
Posts: 1
Joined: Sun Nov 24, 2013 5:06 pm

Re: Scrolling not working on Surface Pro 2

Postby Zenexer on Sun Dec 08, 2013 4:07 am

Having the same problem. It's really annoying. I tried sublime.log_input(True), but nothing gets logged for scrolling. I was hoping maybe it was sending some odd key event.
Zenexer
 
Posts: 1
Joined: Sun Dec 08, 2013 3:58 am

Re: Scrolling not working on Surface Pro 2

Postby frantz on Wed Jul 30, 2014 4:51 pm

I second that issue. Would be nice to have some feedback about that problem from developer. Notice that scrolling works as expected on Lighttable.
frantz
 
Posts: 1
Joined: Wed Jul 30, 2014 4:35 pm

Re: Scrolling not working on Surface Pro 2

Postby trjast on Wed Aug 13, 2014 9:35 pm

Still no changes. I'm running ST3 Build 3059 on a Surface Pro 3 running Windows 8.1 Pro. Two finger scrolling works perfectly in fullscreen view but not in the normal window. It really does make it near impossible to work when I can't scroll.
trjast
 
Posts: 1
Joined: Wed Aug 13, 2014 9:32 pm

Re: Scrolling not working on Surface Pro 2

Postby andersaamodt on Sun Aug 24, 2014 12:12 pm

This is also a problem on my Surface 3. I installed Sublime Text 2 and scrolling worked, but when I disabled DPI scaling (by right-clicking the sublime text .exe and going to the Compatability tab) because it was blurry in Windows 8, the scrolling stopped working. This is a basic feature so I hope it gets working soon!
andersaamodt
 
Posts: 1
Joined: Sun Aug 24, 2014 12:10 pm


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 23 guests