Home Download Buy Blog Forum Support

Sublime is still unusably slow for win 8.1

Sublime is still unusably slow for win 8.1

Postby Roflhouse42 on Mon Jan 20, 2014 11:29 pm

So i have been having this problem for a while now. Sublime Text is unusably slow for me when I run win 8.1. I am seeing visible lag on the scale of half a second. Like i hit the down arrow and .5 seconds later my cursor goes down a line. I have tried a number of things to fix this problem including, turning off indexing, allowing sublime through my firewall, turning off telemetry, not using folders and only opening files directly, turning off animations, removing all addons\packages, and running in compatibility mode. Nothing i try solves this problem.

So some interesting symptoms of this problem revolve around what applications I have running. So if i run only ST3(or ST2 they both have the problem) it will run fine. But if i then open chrome(Pandora), outlook and lync, sublime screeches to a halt. At that point if i close any of the other apps it will run normally, until i open another app. I am by no means taxing my system. i have 12gb of ram and a I7 processor. I am using something like 10% of CPU and 30% memory and 0-4% disk.

I have read somewhere that turning off your firewall could possibly solve this problem but that really isn't an option for me at work. also the task manager isn't registering any unusual activity from the firewall so I find it strange that it would be that.

The final symptom that i find strange is if sublime is being slow while i say only have 2 applications open(which can happen but rarely) then i can get it to run normally if i un-fullscreen it. Like make the window only take up 1/3 of my screen. I run 1900x1200 so on the higher end of resolutions but nothing crazy.

I really really want to use sublime but it simply doesn't work correctly with my setup. I work for a company that does not allow for a wide variety of support applications. So the apps listed above cannot be replaced. Until this problem is fixed or I find an acceptable solution to this problem i have to put sublime text on the shelf and use a different editor. Which is a shame cause i really like sublime, when its working. So please somebody fix this cause i have already spent far to much time trying to find a way around it.
Roflhouse42
 
Posts: 25
Joined: Tue Jul 30, 2013 12:34 am

Re: Sublime is still unusably slow for win 8.1

Postby iamntz on Tue Jan 21, 2014 6:23 am

If you say you tried to revert and you still have issues, there might be a problem with other parts of the system. Maybe some restriction policy, maybe a faulty hardware (i had issues in the past with a faulty SSD: my system went unusable for couple of minute every now and then; but the whole system was slow, not only sublime).

You could try ProcMon and see if there is anything that goes crazy.

I'm using 8.1 and i have no issues.
iamntz
 
Posts: 897
Joined: Fri Apr 29, 2011 8:52 am
Location: Romania

Re: Sublime is still unusably slow for win 8.1

Postby Roflhouse42 on Tue Jan 21, 2014 7:21 pm

I highly doubt its failing hardware seeing as literally the only process acting strangely on my machine is sublime. I have also looked for processes that are overly using the CPU during these slow down periods but I found nothing out of the ordinary. Also if you know of anything which could possibly be restricting sublime in someway I would love to know. But restricting processing power of a process is a fairly high permissions task the only thing that could do that on my system that I think could do that would be my antivirus or windows itself and I cant find anything to suggest that they are. The fact that I can fairly reliably control it now makes me think that is a resource conflict of some kind.
Roflhouse42
 
Posts: 25
Joined: Tue Jul 30, 2013 12:34 am

Re: Sublime is still unusably slow for win 8.1

Postby Roflhouse42 on Tue Jan 21, 2014 10:21 pm

So i think i found what was causing it. Which is funny because i just posted this problem and i have been having it for a while. But i was messing around with my resolution switching between 1920x1200 and 1600x1080. When i noticed i had Enable Stereoscopic 3D settings for all supported displays enabled. My monitor happens to support that so it was turned on. After disabling stereoscopic 3d support i have yet to have the slow down problem for about an hour. I doubt this problem is "solved" as sublime shouldn't be tanking that hard for any reason, i do believe 3D support is some how messing with sublime. If i get the slow down again i will report. But yeah if you have problems with sublime i recommend disabling 3D support. PS. using nvidia quadro FX 380, and 2 monitors. Dell U2410 and Dell 2408WFP.
Roflhouse42
 
Posts: 25
Joined: Tue Jul 30, 2013 12:34 am


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot] and 22 guests