Home Download Buy Blog Forum Support

ST 3 - Winerror 5 Custom Project Python Build System W864bit

ST 3 - Winerror 5 Custom Project Python Build System W864bit

Postby Parks on Thu Apr 10, 2014 2:21 pm

Hey ST-Community,

Today I managed to get some very weird behavior in the Sublime Terminal when I tried to create a custom build system for my project. The build System should run my venv's python interpreter with a given file.

I tried all kind of settings resulting in various errors:

Decode Error - output not utf-8
WinError2 - File not found
WinError5 - Access denied

In the morning there was just the decode error, which I got when trying to run simple print("Hello World!") statements. - I really don't know why this happens when i call the venvs Python3 interpreter. Running the script with the system interpreter, it always runs without errors. WinError2 happend for really no reason, I didn't change the script at all but I had to modify it, in order to find the files again.

Finally, WinError 5 - Access denied happens since I changed it to what I copied below. I have tested it without wrapping the commands in extra double quotes (WinError2), with a "\"cd C:\\Users\\Peter\\Envs\\awake\\awake\" & \"workon awake\" &" prior to the given cmd statement, but still WinError5 remains. Also running ST3 as Admin didn't help.

Edit: Running the Script in any CMD Window works just fine - even without Admin Permission.

I would appreciate any help. Thanks in Advance.
Greets Peter "Parks"


Code: Select all

}
// projects build systems
  "build_systems":
  [
    {
      "name": "python-venv-awake",
      "cmd" : [
                "\"C:\\Users\\Peter\\Envs\\awake\\Scripts\\python.exe\" \"$file\""
              ]
    }
  ]
}
Parks
 
Posts: 2
Joined: Wed Feb 19, 2014 10:33 pm

Return to Technical Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 35 guests