Home Download Buy Blog Forum Support

Jump Forward

Jump Forward

Postby Mabusto on Wed Jun 11, 2014 9:12 pm

I can't tell if I've found a bug or if I just don't understand this feature correctly. When I click around in a text file (move the cursor) and then hit alt+minus, the cursor goes back as expected, but then when I hit alt+shift+minus, nothing happens and "Already at the newest position" appears in the status bar below.

Steps to Reproduce:
- Open a text file.
- Left click to different positions in the file.
- Note where the cursor is.
- Press "Jump Back" once.
- Press "Jump Forward" once.

What happens:
- Cursor does not move. "Already at the newest position" displays in status bar.

What is expected:
- Cursor will move to position it was at previous to pressing "Jump Back".

Sublime Text build 3062. I've found this while editing a .js file on Ubuntu 14.

Perhaps I'm misunderstanding this feature, so I've tried to get "Jump Forward" to work in any scenario, but everyone I've tried the cursor just stays put and "Already at newest position" displays in the status bar.

Is this a bug or am I misunderstanding how to use this? My expectation is that when you Jump Forward, the cursor will do the opposite of what a Jump Back keypress would do, as long as there hasn't been any user initiated cursor moves in between.
Posts: 2
Joined: Wed Jun 11, 2014 9:01 pm

Re: Jump Forward

Postby tito on Thu Jun 12, 2014 5:22 pm

Works for me.

Open file = cursor is at 0,0
Click somewhere in the middle.
Press ALT+- = Cursor jumps to 0,0
Press ALT+SHIFT+- Cursor jumps to middle of the file.

ST 3062 - Windows 7

command: jump_back
command: jump_forward
Give APIs, let the community build the rest!
Posts: 920
Joined: Thu Sep 29, 2011 2:27 pm
Location: Montevideo, Uruguay

Re: Jump Forward

Postby Mabusto on Tue Jun 17, 2014 11:06 pm

I can confirm that this works as expected in Windows 7, ST 3062.

Behaviour is the same as described in ST 3062 in Ubuntu 14.04.
Posts: 2
Joined: Wed Jun 11, 2014 9:01 pm

Re: Jump Forward

Postby shk on Thu Jun 19, 2014 8:55 am


I can confirm that this doesn't work for me as well.
I am on build 3059 on Ubuntu 14.04
This bug has been a pet peeve of mine while using Sublime.
Posts: 1
Joined: Thu Jun 19, 2014 8:53 am

Return to Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 32 guests