Home Download Buy Blog Forum Support

OS X Control-Space not working

OS X Control-Space not working

Postby ryentzer on Thu Aug 04, 2011 8:36 pm

I'm trying to use the trial version of build 2097 on OS X 10.6.8. I cannot get the keyboard shortcut for auto-complete which is ^SPACE to work.
Any ideas?

Thanks, Rick
ryentzer
 
Posts: 8
Joined: Wed Aug 03, 2011 1:14 am

Re: OS X Control-Space not working

Postby jps on Fri Aug 05, 2011 7:30 am

It's possible ctrl+space is intercepted before it gets to the application. For example, it's possible to have ctrl+space interact with Spaces.

Rather than digging around in your system settings, it may be simpler to just rebind it to another key.
jps
Site Admin
 
Posts: 3071
Joined: Wed Mar 19, 2008 12:33 pm

Re: OS X Control-Space not working

Postby pdclark on Wed Sep 14, 2011 5:45 am

Control-Space is reserved by OS X for changing keyboard layouts. Unintuitively, you have to enable the feature to disable the keyboard shortcut (and free up the key combo). To do this:

  • Go to System Preferences > Language & Text > Input Sources
  • Check (turn on) at least two input sources in the left column
  • Click the "Keyboard Shortcuts..." button in the right column
  • Select Keyboard & Text Input on the left
  • Scroll to the bottom and disable "Select the previous input source -- ^Space" on the right
  • Go back to System Preferences > Language & Text > Input Sources
  • Turn off the inputs on the left
pdclark
 
Posts: 3
Joined: Wed Sep 14, 2011 5:11 am


Return to Technical Support

Who is online

Users browsing this forum: qgates and 20 guests