Home Download Buy Blog Forum Support

Bug in Vintage: Leaving Visual Mode with <Esc> doesn't work

Bug in Vintage: Leaving Visual Mode with <Esc> doesn't work

Postby tux. on Fri Aug 05, 2011 1:08 am

So I'm playing a bit with Vintage, and while it looks solid at a first glance, a major issue is that I can't leave Visual Mode with the Escape key. I (obviously) need to use the mouse for returning into command mode - rather unintuitive IMO.
Image
tux.
 
Posts: 96
Joined: Thu Apr 14, 2011 11:04 am

Re: Bug in Vintage: Leaving Visual Mode with <Esc> doesn't work

Postby jps on Fri Aug 05, 2011 1:19 am

You can also press v to exit visual mode
jps
Site Admin
 
Posts: 3058
Joined: Wed Mar 19, 2008 12:33 pm

Re: Bug in Vintage: Leaving Visual Mode with <Esc> doesn't work

Postby tux. on Fri Aug 05, 2011 1:22 am

v is for entering Visual Mode, Esc generally exits any non-command mode AFAIK. So - this behavior is intended?
Image
tux.
 
Posts: 96
Joined: Thu Apr 14, 2011 11:04 am

Re: Bug in Vintage: Leaving Visual Mode with <Esc> doesn't work

Postby jps on Fri Aug 05, 2011 1:46 am

v is for several things in different circumstances, and one of them is exiting visual mode.

I'm not saying escape shouldn't exit visual mode, I'm just saying there's already a way to do so. As mentioned in the initial post, there are plenty of things Vintage doesn't do yet.
jps
Site Admin
 
Posts: 3058
Joined: Wed Mar 19, 2008 12:33 pm

Re: Bug in Vintage: Leaving Visual Mode with <Esc> doesn't work

Postby tux. on Fri Aug 05, 2011 2:03 am

Well, thanks for clarifying that then. :)
The fact that :w works but :q does not is known then, too?

I'm looking forward to upcoming updates anyway. I hope I can help you finding more of these issues ...
Image
tux.
 
Posts: 96
Joined: Thu Apr 14, 2011 11:04 am


Return to Technical Support

Who is online

Users browsing this forum: becker101, Google [Bot], Johannes and 18 guests