Home Download Buy Blog Forum Support

Font Setting & Build Problem

Font Setting & Build Problem

Postby Autarc on Wed Aug 24, 2011 12:22 am

Hio guys,

Thanks to your help I could now run Sublime at Arch. It's awesome and replaced Aptana completly :)
Unfortunately I got a few problems, for which you could hopefully give me some advice.

Problem # 1 -
I'd like buymeasodas soda-theme & the modified color-scheme. Since the font seems promising, I'd installed Meslo LGtoo. To activate it, I added the following line into the 'Global Settings - User': "font_face": "Meslo LG". Dunno why, but the fon't doesnt change. Is anything wrong with the font name or the declaration itself ?

Problem # 2 -
I'am currently digging into node.js. Therefore I did a build which would run my code through node:

"cmd": ["node", "$file"]
"selector" : source.js",
"path" : "/usr/bin"

So far it works for my server.js. But as I wanted to restart it after a modification, I get the error "node.js:134 ... Address already in use". If I would run the file in a terminal, I would just use crtl+c to close it. But this didn't work right now. Did this happend to some of you before ? Any "nice" solution, which still allows to run the script via node from sublime (~ perhaps with another shortkey-cut) ?

Moreover, is there a way to automaticly starting a shell script/browser which points to the specific adress (e.g. localhost:8888 ), which triggers right after node runs the script ?

additional Question # -
Has anyone a good solution for compiling a .coffee file and running it in node through one build (or at least saving the compiled JavaScript code in a file, which will be executed afterwards). Would be good know ;)
Autarc
 
Posts: 4
Joined: Wed Aug 17, 2011 9:15 pm

Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot], Google [Bot] and 22 guests