Home Download Buy Blog Forum Support

ST2 (b#2109 OS X) not following relative symbolic links

ST2 (b#2109 OS X) not following relative symbolic links

Postby rocketman on Wed Aug 31, 2011 7:18 pm

I just noticed that folders that are symbolically linked via a relative url (eg: ../../folder/another) are shown as folders in the tree, but show nothing when opened. Absolute symbolic links however do work (eg: /Home/user/folder/another). However I did have to restart ST2 before it picked up the change I had made to the symbolic link when i deleted the relative link and created a new absolute one.
rocketman
 
Posts: 17
Joined: Wed Jul 27, 2011 5:29 pm

Re: ST2 (b#2109 OS X) not following relative symbolic links

Postby nxa244 on Mon Dec 12, 2011 4:09 pm

Hello. Just wanted to check to see if this is something that will be fixed. We have a number of projects that share a common set of library files, which are relative symlinks in each folder. Unfortunately, we don't have the flexibility to make these absolute so is pretty much a critical feature for us.

Thanks
nxa244
 
Posts: 1
Joined: Mon Dec 12, 2011 4:05 pm

Re: ST2 (b#2109 OS X) not following relative symbolic links

Postby SyntaxPickax on Thu Aug 23, 2012 9:39 pm

I also have some projects that rely on relative symbolic links. ST2 unfortunately does not follow them when opening files. This would seem like an easy fix. Is it in the works?
SyntaxPickax
 
Posts: 1
Joined: Thu Aug 23, 2012 9:35 pm


Return to Technical Support

Who is online

Users browsing this forum: Bueddl, Majestic-12 [Bot], Yahoo [Bot] and 29 guests