Home Download Buy Blog Forum Support

How do I fine tune or disable autocomplete?

How do I fine tune or disable autocomplete?

Postby aple on Wed Sep 07, 2011 7:59 pm

Not sure if it's enabled by Zen-Coding, CodeIntel, or what, but every now and then ST will interrupt my typing to insert some value it assumes I want. For instance, if I'm editing css and type in:
Code: Select all
#div {
    background:url(img/bg.jpg) no-


It will automatically finish off that word for me:
Code: Select all
#div {
    background:url(img/bg.jpg) none-


Any suggestions?
aple
 
Posts: 42
Joined: Fri Aug 19, 2011 12:42 pm

Re: How do I fine tune or disable autocomplete?

Postby tib on Sat Sep 24, 2011 6:48 pm

You can disable CodeIntel live autocomplete if you put this two line:

"codeintel_live" : false,
"codeintel_disabled_languages": ["css"]

to File settings - user. ;)
tib
 
Posts: 1
Joined: Sat Sep 24, 2011 6:46 pm

Re: How do I fine tune or disable autocomplete?

Postby brickattack on Tue Sep 27, 2011 3:13 am

I think the real issue is that the autocomplete shouldn't happen on a hyphen. This happened to me so much when typing objects in PHP that CodeIntel became an unusable plug-in. I was told by the plug-in's creator that it's an ST2 API issue https://github.com/Kronuz/SublimeCodeIntel/issues/5#issuecomment-2150998. It stinks because CodeIntel is very handy when trying to dig through classes.
@brickattack ST2 OS X
brickattack
 
Posts: 14
Joined: Fri Apr 22, 2011 5:19 pm


Return to Technical Support

Who is online

Users browsing this forum: Exabot [Bot] and 23 guests