Home Download Buy Blog Forum Support

[BUG] Shift + V issues (vintage)

[BUG] Shift + V issues (vintage)

Postby ceej on Sat Sep 10, 2011 2:43 pm

Hi,

There's an issue with vintage modes shit + v selecting text below works just fine, but when you select text above where you pressed shift + v the original line you had highlighted becomes un-highlighted which is a bug. I use this feature every day and is becoming an absolute pain to deal with. Does anyone know the file and line number that handles this? I would love to patch it myself to save my sanity LOL!

Many thanks
ceej
 
Posts: 81
Joined: Tue Jun 21, 2011 5:37 pm

Re: [BUG] Shift + V issues (vintage)

Postby ceej on Mon Sep 12, 2011 1:38 pm

I'm surprised other ex vim users aren't being driven made by this bug.....I'm sure it's an easy fix too.
ceej
 
Posts: 81
Joined: Tue Jun 21, 2011 5:37 pm

Re: [BUG] Shift + V issues (vintage)

Postby jps on Mon Sep 12, 2011 2:35 pm

This doesn't happen for me: typing "Vk'" in the middle of a file will leave two lines selected
jps
Site Admin
 
Posts: 3062
Joined: Wed Mar 19, 2008 12:33 pm

Re: [BUG] Shift + V issues (vintage)

Postby ceej on Mon Sep 12, 2011 2:44 pm

Thank you for the response, use the UP key instead of k.
ceej
 
Posts: 81
Joined: Tue Jun 21, 2011 5:37 pm

Re: [BUG] Shift + V issues (vintage)

Postby jps on Mon Sep 12, 2011 3:40 pm

The arrow keys (and also home/end/pageup/pagedown) aren't yet bound to motions in vintage mode, which will cause what you're seeing.
jps
Site Admin
 
Posts: 3062
Joined: Wed Mar 19, 2008 12:33 pm

Re: [BUG] Shift + V issues (vintage)

Postby ceej on Tue Sep 13, 2011 3:30 pm

Ah k, do you know when this will be added? Is it a hard thing to put in myself?

Many thanks.
ceej
 
Posts: 81
Joined: Tue Jun 21, 2011 5:37 pm

Re: [BUG] Shift + V issues (vintage)

Postby guillermooo on Tue Sep 13, 2011 3:56 pm

Take a look at Packages/Vintage/Default.sublime-keymap and look for "h", "j", "k", "l". That should give you an idea how to map the arrow keys.
guillermooo
 
Posts: 723
Joined: Thu Jul 23, 2009 9:06 am


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 13 guests