Home Download Buy Blog Forum Support

Very slow and so nearly unusable on MacOS 10.6

Very slow and so nearly unusable on MacOS 10.6

Postby andi on Sat Sep 10, 2011 10:21 pm

I use Mac OS 10.6 on a MacBook 13" (2007). It is hanging. I always see the Mac OS' spinner cursor and it reacts after 1...30 secs after clicks. So I cannot really use it despite I'd like to. Sometimes, after some minutes, it works normally, but I don't want to wait after every restart.
I don't know what could cause this slow reaction. Any system or editor prefs that could help me?
Thanks

Andi
andi
 
Posts: 7
Joined: Sat Sep 10, 2011 10:17 pm

Re: Very slow and so nearly unusable on MacOS 10.6

Postby MrMartineau on Sat Sep 10, 2011 11:35 pm

Have you installed the tagmatcher or bracket matcher plugins? They caused Sublime to be nearly unusable too, so after uninstalling them everything was back to normal
@MrMartineau || Setup Sublime Text quickly: Find out all you need at https://github.com/mrmartineau/SublimeTextSetup
MrMartineau
 
Posts: 78
Joined: Thu Jul 28, 2011 8:35 am

Re: Very slow and so nearly unusable on MacOS 10.6

Postby andi on Tue Sep 13, 2011 7:47 pm

I have not manually installed any plugins. A search for tagmatcher does not give me any results. Where can I find plugins and how can I uninstall them?
andi
 
Posts: 7
Joined: Sat Sep 10, 2011 10:17 pm

Re: Very slow and so nearly unusable on MacOS 10.6

Postby MrMartineau on Wed Sep 14, 2011 6:15 pm

Click the link in my signature below to read my post about using ST.
@MrMartineau || Setup Sublime Text quickly: Find out all you need at https://github.com/mrmartineau/SublimeTextSetup
MrMartineau
 
Posts: 78
Joined: Thu Jul 28, 2011 8:35 am

Sublime Text is now hanging forever

Postby andi on Fri Nov 25, 2011 7:53 pm

(I do not need any extensions and so I have not installed them.)
Sadly, Sublime Text is now hanging forever. So I have switched to Gedit again. It's weird that I need to stop using the best editor on a Mac just because it is hanging without reason. What can I do?
andi
 
Posts: 7
Joined: Sat Sep 10, 2011 10:17 pm

Re: Very slow and so nearly unusable on MacOS 10.6

Postby C0D312 on Fri Nov 25, 2011 8:03 pm

C0D312
 
Posts: 1063
Joined: Sun Jul 10, 2011 3:23 am

Re: Very slow and so nearly unusable on MacOS 10.6

Postby andi on Sat Nov 26, 2011 4:26 pm

Thanks, but it's still blocking for many seconds. It just reacts every 10-20 seconds to my inputs. It seems that there is some logic inside that blocks on older MacBooks.
andi
 
Posts: 7
Joined: Sat Sep 10, 2011 10:17 pm

Re: Very slow and so nearly unusable on MacOS 10.6

Postby wbond on Mon Nov 28, 2011 2:55 pm

How many files are in the folder you have loaded into the sidebar?

Are you trying to use a folder over Expandrive, Fuse, or a Samba share?
wbond
 
Posts: 528
Joined: Mon Feb 28, 2011 5:33 am

Re: Very slow and so nearly unusable on MacOS 10.6

Postby andi on Mon Nov 28, 2011 10:40 pm

I do not use any remote file system.
I usually load my home dir, or a sub dir, where all my modules are in (usually 20-30 dirs, each can contain many files).
This shouldn't be a problem.
And I believe that my SSD should make the whole process faster instead if slower (?).
andi
 
Posts: 7
Joined: Sat Sep 10, 2011 10:17 pm

Re: Very slow and so nearly unusable on MacOS 10.6

Postby farfromrefuge on Tue Nov 29, 2011 7:37 am

I have exactly the same problem. And i narrowed it down to the sidebar/project view.
As soon as i show it i get 100% cpu usage (with the latest dev build at least, dont remember it with the older one).
In my project i had 2 folders(those folders contain thousands of files)

Hope it helps
farfromrefuge
 
Posts: 38
Joined: Mon Oct 19, 2009 11:49 am

Next

Return to Technical Support

Who is online

Users browsing this forum: No registered users and 31 guests