Home Download Buy Blog Forum Support

Unable to install package control

Unable to install package control

Postby ackernaut on Wed Sep 21, 2011 2:44 am

I attempted to install Package Control (http://wbond.net/sublime_packages/package_control) and now am getting the following error:

Unable to run package setup:

Traceback (most recent call last):
File "./PackageSetup.py", line 155, in upgrade
upgradePackage(pkg, pristinedir, datadir, backupdir)
File "./PackageSetup.py", line 148, in upgradePackage
os.path.join(backupdir, base), inhibitOverwrite)
File "./PackageSetup.py", line 31, in upgradeArchive
newar = zipfile.ZipFile(src)
File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/zipfile.py", line 696, in __init__
File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/zipfile.py", line 716, in _GetContents
File "/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/zipfile.py", line 728, in _RealGetContents
zipfile.BadZipfile: File is not a zip file

I'm on OS X 10.7.1

I can't get Sublime Text to start anymore.
ackernaut
 
Posts: 2
Joined: Wed Sep 21, 2011 2:40 am

Re: Unable to install package control

Postby ackernaut on Wed Sep 21, 2011 3:36 pm

All fixed, starting with a fresh state:

http://www.sublimetext.com/docs/2/revert.html
ackernaut
 
Posts: 2
Joined: Wed Sep 21, 2011 2:40 am


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 19 guests