Home Download Buy Blog Forum Support

Settings Problem

Settings Problem

Postby yarkot on Wed Sep 28, 2011 11:10 pm

Hi -

I'm trying out SublimeText 2 (on recommendation of a friend).

I was happy to find "Vintage" support (e.g. vi-mode), so I could get "right to using it" (fingers have old habits!).

A couple of comments:

I edited the settings: "ignored_packages" so as to enable global mode - in the Global settings (unfortunately).

When a new build / update came (today), I lost that setting, so I tried setting in user settings (without changing the global settings) - it didn't work.
I confirmed that if:
[1] I remove the settings in global, then user will take effect;
i.e. global: // "ignored_packages":["Vintage"]
user: "ignored_packages":[]
[2] I set in global, then that takes effect

So it seems that you are doing something like a union of settings lists, rather than an override
i.e. a settings["ignored_packages"].append( user["ignored_packages"] ) is what it seems to behave like,
rather than settings["ignored_packages"]=user["ignored_packages"] (which is what I expect).

Also (a nit), while turning this "on" and "off" to be sure I had it right, I tried commenting out the various lines in question,
only to get parse errors (trailing comma); it would be nice if you tolerated trailing commas as pre-cursors to "no element", much like python lists do.

Thanks - looks like a nice product so far!

P.S. - what would I do to see a particular setting in the console?
Posts: 1
Joined: Wed Sep 28, 2011 10:49 pm

Return to Technical Support

Who is online

Users browsing this forum: No registered users and 17 guests