Home Download Buy Blog Forum Support

Vintage (vim) and bookmarking

Vintage (vim) and bookmarking

Postby chadwtaylor on Sun Oct 09, 2011 9:37 pm

To bookmark in Vintage mode:

ma (marks bookmark to "a")

To travel to the bookmark "a"

'a

But it doesn't work in Vintage mode... anybody know about this?
chadwtaylor
 
Posts: 3
Joined: Sun Oct 09, 2011 9:09 pm

Re: Vintage (vim) and bookmarking

Postby guillermooo on Sun Oct 09, 2011 10:00 pm

Try a backquote (grave accent) instead:

Code: Select all
`a
guillermooo
 
Posts: 729
Joined: Thu Jul 23, 2009 9:06 am

Re: Vintage (vim) and bookmarking

Postby chadwtaylor on Mon Oct 10, 2011 4:18 pm

guillermooo wrote:Try a backquote (grave accent) instead:

Code: Select all
`a


That worked, thanks. Will have to get used to this one esp after using VIM for over 15+ years.
chadwtaylor
 
Posts: 3
Joined: Sun Oct 09, 2011 9:09 pm

Re: Vintage (vim) and bookmarking

Postby adzenith on Mon Oct 10, 2011 4:32 pm

The keybindings are also 100% customizable, so you could just add 'a maybe?
adzenith
 
Posts: 1217
Joined: Mon Oct 19, 2009 9:12 pm

Re: Vintage (vim) and bookmarking

Postby guillermooo on Mon Oct 10, 2011 6:31 pm

Actually, the semantics are different between ' and ` in Vim... I'd like for both to work also because because typing ` in my Spanish keyboard is cumbersome. I haven't tried remapping ' as adzenith suggests, but it might work.
guillermooo
 
Posts: 729
Joined: Thu Jul 23, 2009 9:06 am

Re: Vintage (vim) and bookmarking

Postby askeeve on Tue May 22, 2012 5:05 pm

It seems like moving to marks doesn't work with delete ('d') or yank ('y') and potentially other commands with movement modifiers. Is the ` not considered a motion command? Could it be/is it easy to modify for myself. A common technique would be to mark the end of a function and then delete from the beginning of the function to that mark. This doesn't seem to be possible unless I'm doing something wrong.

Also the `` command which is supposed to take you to the position before the last jump doesn't seem to work.
askeeve
 
Posts: 51
Joined: Wed Apr 18, 2012 1:33 pm


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot], Majestic-12 [Bot], Yahoo [Bot] and 31 guests