Home Download Buy Blog Forum Support

Crash on startup (OS X)

Crash on startup (OS X)

Postby dacort on Fri Oct 14, 2011 3:54 pm

OS X grey-screened on me yesterday. Now when I try to open Sublime, it starts loading old windows it had, but then crashes immediately (no crash log or error) after a few of them have loaded. In my system log, there are a couple relevant error messages:

unrecognized button type 7

and
com.apple.launchd.peruser.501[181] ([0x0-0x90090].com.sublimetext.2[1548]) Exited abnormally: Broken pipe


I assume I can blow away my Auto Save Session file, but wanted to at least mention the crash.
dacort
 
Posts: 4
Joined: Tue Jul 05, 2011 10:25 pm

Re: Crash on startup (OS X)

Postby jps on Fri Oct 14, 2011 11:03 pm

It'd be handy if you could email the crash report (from the Console application) to support@sublimetext.com
jps
Site Admin
 
Posts: 3062
Joined: Wed Mar 19, 2008 12:33 pm

Re: Crash on startup (OS X)

Postby dacort on Mon Oct 17, 2011 10:20 pm

There is, unfortunately, no actual crash report. But I'll send over my auto save session file and see if that helps.
dacort
 
Posts: 4
Joined: Tue Jul 05, 2011 10:25 pm

Re: Crash on startup (OS X)

Postby dacort on Wed Oct 19, 2011 6:08 pm

That's really odd. I tried to start up Sublime again today, and it crashed again with no crash log. I opened the "Auto Save Session.sublime_session" file in vim to try to find a large json file that Sublime was trying to load when it crashed. I tried to open Sublime again while I had that file open in vim...and it fired up just fine.
dacort
 
Posts: 4
Joined: Tue Jul 05, 2011 10:25 pm


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 6 guests