Home Download Buy Blog Forum Support

Two problems with Linux and the lates Build (2126)

Two problems with Linux and the lates Build (2126)

Postby paper82 on Tue Oct 25, 2011 11:29 am

Since Build 2126 I noticed two problems. I am working with Linux, Debian Squeeze 64 / XFCE.

1. When I open a filename with spaces from Thunar, sublimetext splits the filename on the spaces
and opens for every part a new empty file.
e.g.: My file.txt -> opens two tabs My and file.txt

2. My global settings for the User looks like:
{
"remember_open_files": false
}

But - open files are still rememberd.

Can someone give me hints / input?

Thank you very much,
Roland
paper82
 
Posts: 1
Joined: Sat May 28, 2011 6:02 am

Re: Two problems with Linux and the lates Build (2126)

Postby slestak989 on Tue Oct 25, 2011 1:28 pm

I will check on my Fedora 15 2126 install.

The remember open files acts the same. setting it to false in my Global.sublime-settings User doesn't appear to have an effect.

In Gnome 3 nautilus, opening a file with a space in it worked for me.
Using ST2 on: Win7 Pro 64 || Win7 32|| Fedora 16
slestak989
 
Posts: 31
Joined: Tue Oct 04, 2011 3:40 am

Re: Two problems with Linux and the lates Build (2126)

Postby xavi on Tue Oct 25, 2011 5:39 pm

paper82 wrote:Since Build 2126 I noticed two problems. I am working with Linux, Debian Squeeze 64 / XFCE.

1. When I open a filename with spaces from Thunar, sublimetext splits the filename on the spaces
and opens for every part a new empty file.
e.g.: My file.txt -> opens two tabs My and file.txt

2. My global settings for the User looks like:
{
"remember_open_files": false
}

But - open files are still rememberd.

Can someone give me hints / input?

Thank you very much,
Roland


1) I don't use thunar, but I've no problem with nautilus.
2) Same problem here. I've remember_open_files to false in user Global.sublime-settings but editor starts opening files =(

Any help?
xavi
 
Posts: 24
Joined: Sat Jul 30, 2011 12:00 am

Re: Two problems with Linux and the lates Build (2126)

Postby xippi on Thu Nov 10, 2011 9:19 am

I'm having same problem with filename with spaces, no matter what file manager I'm using. I use Linux/Gnome

Same problem appears on 2126 and 2139 builds. Any help ?
xippi
 
Posts: 2
Joined: Tue Nov 08, 2011 2:03 pm

Re: Two problems with Linux and the lates Build (2126)

Postby jps on Thu Nov 10, 2011 10:37 am

Sublime Text has no issues with spaces in file names. Perhaps you're launching it via a shell script that's not quoting them properly.
jps
Site Admin
 
Posts: 3077
Joined: Wed Mar 19, 2008 12:33 pm

Re: Two problems with Linux and the lates Build (2126)

Postby xippi on Thu Nov 10, 2011 12:01 pm

you were right. prob appeared because unquoted $@ sees arguments as separate words. thanks
xippi
 
Posts: 2
Joined: Tue Nov 08, 2011 2:03 pm

Re: Two problems with Linux and the lates Build (2126)

Postby farrelle25 on Tue Nov 15, 2011 12:13 am

--
Linux 32-bit - Dev Build 2143
--

I can't get Sublime to open a file name with spaces from the command line.
But files with spaces work using another editor.

e.g. both these work correctly for leafpad editor
leafpad some\ test\ file.txt
leafpad "some test file.txt"


But neither works with Sublime - it creates 3 empty tabs
sublime-text-2 some\ test\ file.txt
sublime-text-2 "some test file.txt"


Should I put something else around the file name?
cheers..
farrelle25
 
Posts: 9
Joined: Tue Aug 30, 2011 7:04 pm

Re: Two problems with Linux and the lates Build (2126)

Postby jps on Thu Nov 17, 2011 10:17 pm

farrellee25: As posted above, please stop using a shell script, use a symlink instead
jps
Site Admin
 
Posts: 3077
Joined: Wed Mar 19, 2008 12:33 pm

Re: Two problems with Linux and the lates Build (2126)

Postby jps on Thu Nov 17, 2011 10:18 pm

With respect to remember_open_files, hot_exit also needs to be set to false from 2126 onwards
jps
Site Admin
 
Posts: 3077
Joined: Wed Mar 19, 2008 12:33 pm

Re: Two problems with Linux and the lates Build (2126)

Postby farrelle25 on Mon Nov 21, 2011 9:27 pm

-----------
Re: opening file names with spaces

Heres a tip for any Ubuntu users who get the latest sublime .deb from:

https://launchpad.net/~webupd8team/+archive/sublime-text-2


edit this file (its not a binary):
/usr/bin/sublime-text-2

change:
/usr/lib/sublime-text-2/sublime_text $*

to:
/usr/lib/sublime-text-2/sublime_text "$*"

save file.

Sublime now opens file names with spaces from the command line.
farrelle25
 
Posts: 9
Joined: Tue Aug 30, 2011 7:04 pm


Return to Technical Support

Who is online

Users browsing this forum: Google [Bot] and 15 guests